powered by Jive Software

Cant upload archive.jar

I seem to be having an issue loading the open archive plugin on openfire 3.4.1. i downloaded archive-1.0.4.jar and renamed it to archive.jar and tried to upload it, in the plugin section of the web interface of openfire. I immediately get a red bar at the top of the screen stating “Unable to upload plugin. See server error logs.” when i see the error logs all that it says is, "org.jivesoftware.openfire.admin.plugin_002dadmin_jsp._jspService(plugin_002dadmi n_jsp.java:159)

Plugin manager failed to install plugin: C:\archive.jar"

has anyone seen something like this before, and/or know how to make this work? i am very interested in testing out this serverside message logging, and this seems to be the best/only way to accomplish this task.

oops, that wasnt supposed to be crossed out … the error message was enclosed in brackets so it just put a line through the entire message. the error message says:

org.jivesoftware.openfire.admin.plugin_002dadmin_jsp._jspService(plugin_002dadmi n_jsp.java:159)

Plugin manager failed to install plugin: C:\archive.jar

No one has any ideas huh ? It is very important that i am able to keep a server-side log of all message communications, as part of the compliance regulations of this company. if i dont have that option then i wont be able to continue using openfire; which would be sad, becasue this application is the best i have seen in a LONG time, as jabber servers go !

If anyone has ANY ideas or just random thoughts as to how i may attempt this differently, please dont hesitate to post. At this point i am willing to try anything !!

Hi,

I’m not sure I could help. I guess it’s an issue of Openfire version upgrade from 3.3 to 3.4. I got the same problem using my Botz class Botz: Internal Bot Library for Openfire. That’s why I have separate versions of the library for different Openfire versions. However, the better thing for you to do is to ask the developer directly @Stefan Reuter.

i have tried to contact Stefan, but im sure he is a very busy person ! let me just toss this out to see if maybe this is a simple problem to fix …

java.io.FileNotFoundException: C:\Program Files (x86)\Openfire\plugins\C:\Program Files (x86)\Openfire\plugins\archive.jar.part (The filename, directory name, or volume label syntax is incorrect)

This is from my error log when placing archive.jar directly into my plugins folder for openfire and restarting. and the plugin does actually load (kida) all of the functionality is not there, but a lot of it is. And it is now listed in my installed plugin page. Anyhow, it seems to me that it is messing up becasue it is putting the path to the file in twice. would this be in the code for the plugin, or the code for openfire? and if anyone knows the answer to that, would you also happen to know where ? maybe i can just go in and find a way to fix the double path issue.

Though now that im looking at it a bit more carefully, what is this archive.jar.part ? even if the path was correct, i dont have that file at all ?

Anyone that may be able to help i would be very greatful, this archive issue is killing me !

Hi,

there are two problems here. One is related to the fact that I currently don’t have a windows installation available that I could use for testing and this seems like a Windows specific issue as I was unable to reproduce it on other systems.

The other issue that your requirements for compliance sounds more like you should be using Openfire Enterprise. It includes an archive designed for compliance purposes, comes with full support from Jive Software and you activly support the free development of Openfire by paying a few bucks for the commercial usage

=Stefan

Stefan,

Thank you for the reply. Though it would have been nice to have a free version of this software work for me, i think that you may be right about needing the enterprise edition. I am contacting jivesoftware now to figure out the pricing for my needs. i appreciate your replies, and cant wait to see what else you have in store, in regards to upcoming plugins and upgrades !