Change default Server text box


Is there a way to change the default default server that appear in the text box in the login screen? I’ve was searching into sparkweb something in the source code, but I didn’t find anything.

Could you help me?

I meant: it appears and I’d like to choose the default server that is shown in login screen…

You should edit sparkweb.html

Has this ever been answered? I’ve changed my sparkweb.html file, but the default server is still listed as even when opened from another machine and/or browser.

I would like to know this as well. I have changed the server in SparkWeb.html, but the server name listed by default on the page is still

It should have taken effect already, you just need to clear your internet browsers cache

I’ve tried clearing the cache, I’ve tried loading the page from another computer etc… it still loads with as default in the server box. If I type it in and log in, it will store the new server name locally and load with that server name next time; but if I clear the cache or load the page with a clean browser, it will default back to

Stacey, try clearing your flash settings. Right-click on the SparkWeb page, and go to global settings. Then, either delete all, or go to “Local Storage Settings by Site” and delete I did this, reopened my browser, and it fixed it.

I’ve already tried clearing the cache(s), including flash; and tried on a test machine(s) with a clean install. It is not a local cache issue.

You need to run a Flash decompiler (there are several you can download for a free trial) on SparkWeb.swf.

Then you need to edit the default server on line 23 in


Then recompile the .swf

That should read com/jivesoftware not jivestore

Why would you want to decompile when you can get the source code from here ard

Even if you change the default name in the source code, if you don’t remove the FLASH cookie (local shared object), you will still have entries in the pull-down list.

I stand corrected.

Sorry Dele for ignoring all your hard work in maintaining and publishing the source code.

No problem.

Unfortunately, I am not free right now to continue working on the source code, but it is there on the SVN for public access.