powered by Jive Software

Changing Java Memory on Openfire 3.6.4 Ubuntu 9.10 Deb Install

Just FYI. I noticed some other Ubuntu people posting problems with changing the allocated Java Memory.

I also had some trouble changing the Java Memory parameter on my Openfire server. I’m running 3.6.4 on Ubuntu 9.10 and installed using the Deb installation file.

I have browsed the support forums for possible answers, however none of the solutions work for the 3.6.4 version of Openfire. My server starts from a script called “openfire” located at /etc/init.d/ . The configuration options file (“openfire”) is located at /etc/default .

I tried adding a line to either the startup script or the configuration with either of the following:

OPENFIRE_OPTS="-Xms512m -Xmx1024m"

INSTALL4J_ADD_VM_PARAMS="-Xms512m -Xmx1024m"

Neither parameter works. In the startup script, there was NO line that originally said OPENFIRE_OPTS= The configuration reads DAEMON_OPTS=

So what I did was change the line to read DAEMON_OPTS="-Xms512m -Xmx1024m"

sudo gedit /etc/default/openfire -

DAEMON_OPTS="-Xms512m -Xmx1024m"

Then restarted openfire -

cd /etc/init.d/

./openfire restart

Solved my problem Thanx!