powered by Jive Software

Changing wildfire''s port assignment from 5222 to 80

Hello all,

I have been trying to change the default port that wifi uses from 5222 to port 80.

Is this even possible? I have read lots of posts that require a port change to port 80 for the admin interface but not for the client (in my case Spark and jwchat).

I went into the admin client and changed it to port 80 and after a restart, I see port 5223 as the only active port.

TIA!!

Hi,

there is no need to use port 80. You must be root to open a port below 1024 so this is usually not a good idea and will fail if you are not root. For JWChat you need a servlet container like Tomcat, it usually listens on port 8080 and has nothing to do with Wildfire.

JWChat itself connects to wildfire:5222 so changing this port is also there no good idea.

LG

Thanks LG,

The main reason I was trying to do this is that my location has outbound port 5222 among others (9090, etc…) blocked so for me to connect to my Wifi server, I have to port forward through a ssh connection. I was trying to prevent this.

I was able to successfully use port 81 and connect (once again through ssh) to my wifi server via Spark so I was wondering why I could not connect to 80. In the admin console if I select port 80 and save changes it will only show 5223. If I select port 81 and save, it will show both 5223 and 81. I thought that perhaps something else was using port 80 but netstat says otherwise.

Any ideas?

Thanks!

I believe that the reason that you can not change the port 5222 to 80 is that you need to broswer the admin web config page by using the port 80. If you change the Jabber port from 5222 to 80, how can you log onto the configuration as an admin user? Also the port 80 is configured by your network admin for HTTP broswering, not allowed to be modified in most companies.

Regards,

Frank

Hi,

so if you connect now to port 80 using a normal browser you get no response? Probably you have an inetd running which starts a web server as soon as you try to connect to port 80?

But why do you not just open the firewall for port 5222? This would be much more easy.

LG

I thought that the admin console was port 9090?

I even went as far as tunneling with a port forward to port 80 so I would not believe that there is some restriction on type of traffic on port 80. As I said earlier, I can successfully add port 81 as a client port. So if you go into your admin console and try to change the client port from 5222 to port 80 and hit save, they would see that the client port disappears in the Server Settings page. If you do the same with port 81 you continue to see the client port.

I wish I could , unfortunately I dont have the authority nor could I even get them to open this port.

If you look at my other reply pertaining to the admin console see what you think. Perhaps you could go into your admin console and try briefly changing your client port to 80 and then 81 and see if you get the same results.

Here is what I am doing:

  1. Change the client port to 80 in the wifi admin console

  2. Change the Spark port to connect to port 80 (under the advanced link)

  3. try to connect to my chat server through Spark.

Unsuccessful

  1. Change the client port to 81 in the wifi admin console

  2. Change the Spark port to connect to port 81 (under the advanced link)

  3. try to connect to my chat server through Spark.

Successful!

Thanks again LG!

Hi,

it seems to be indeed very hard (=impossible) to change this port to 80 using the admin console edited: may have been a browser caching problem for me. But editing xmpp.socket.plain.port in table JIVEPROPERTY to 80 does also solve this problem.

LG

PS: netstat -an looks like this

Proto Local Address Foreign Address State

TCP 0.0.0.0:80 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5223 0.0.0.0:0 LISTENING

TCP 0.0.0.0:5269 0.0.0.0:0 LISTENING

TCP 0.0.0.0:7777 0.0.0.0:0 LISTENING

TCP 0.0.0.0:9090 0.0.0.0:0 LISTENING

TCP 0.0.0.0:9091 0.0.0.0:0 LISTENING

TCP 192.168.1.1:80 192.168.1.1:1582 ESTABLISHED

TCP 192.168.1.1:1582 192.168.1.1:80 ESTABLISHED # Spark

/code

I’‘m running Wildfire on Port 80 with SSL and on Port 5222 for non-SSL and it works fine as long as you don’'t have a Webserver running on the same machine using port 80. Otherwise you have to change the Webserver port (e.g. 8080).

On the client side (I’'m using PSI) you have to activate SSL and enter Port 80 and the server name.

This is quite usefull because clients can connect through standard web port 80 and the SSL connections prevent most of the firewalls to check the content for chat blocking

Hi AcSe,

this is an interesting option, using (old) SSL on port 443 could make even more sense.

LG

Yes, you’‘re absolutely right, this is even a better idea than using port 80. I’'m gonna try it out.

Thanks

Achim

I am using the embedded database for now, Is JIVEPROPERTY editable throught the embedded database? Through sql I am assuming?

Thanks again!

Hi,

no, no SQL. Stop Wifi, copy conf/wildfire.script to wifi.backup and edit conf/wildfire.script. It is a text sql file, so you will find it very easy to edit it.

LG

LG,

thanks again for all of your help. I marked this as answered since you answered above.

I see wildfire.xml in the conf directory.

No wildfire.script or similar.

embedded-db/wildfire.script is the rigth one