powered by Jive Software

Chat de voz en spark

Buen día para todos, estoy usando en mi compañía el openfire y el spark, el chat de texto funciona perfecto, dentro de la empresa y por fuera está correcto, hasta en los celulares me funciona bn, PERO el icono de chat de voz no me aparece en el spark, no se que es lo que tengo que activar para que los usuarios puedan iniciar el chat de voz.

En un principio pensé que por defecto esta característica se activa con solo instalar el spark, pero no es así. Por favor si me pueden ayudar se los agradezco.

Uso el openfire 3.8.2 (última versión) y el spark 2.6.3

Gracias

No se si te sirva, pero lo que yo pude habilitar fue la videconferencia. Para que sea puro audio la verdad no he encontrado como hacerle, se supone que se puede con el mismo de la videoconferencia, pero no se si me hace falta algun plugin en el cliente spark o en el servidor.

Si te interesa, lo de la videoconferencia te dejo la liga para que puedas hacela funcionar.

https://code.google.com/p/redfire/

la version que yo instale es la redfire-371-0.3.00.zip

Por si te sirve, yo tengo instalado el openfire sobre windows 7 y mis clientes spark los tengo en xp, windows 7. Con windows 8 tengo problemas con el viedo, ya que no se ve correctamente, pero el audio se escucha bien.

Hola Heber, gracias por tu aporte. Te cuento que yo trabajo sobre ubuntu. Realmente soy bastante nuevo en esto, como te decía el chat de texto y transferencias de archivos me funcionan y me he familiarizado muy bien, pero sigo sin poder hacer correr el videochat

Me imagino que debo desinstalar todos los jingle nodes, pues bien eso hice y ellos solitos vuelven a reinstalarse.

cuando salgan los usuarios borraré los plugin y reiniciaré el servicio de openfire, para ver si es eso.

Me queda la duda de como instalo plugin en spark, es decir, hay unos predeterminados para instalar, como le hago para adicionar alguno nuevo, solo me da la opción de instalar plugin que se encuentran en cierto lugar.

Gracias

Yo tambien soy nuevo en esto, asi no esperes de mi una respuesta muy tecnica jejeje

En estos dias estuve haciendo pruebas para la parte del audio chat y ya me esta funcionando. Te comento lo que hice y lo que tendrias que hacer, solo habria que buscar su equivalente para linux.

En primera, como te comente, en donde tienes instalado tu servidor openfire, debes de agregar el plugin de redfire.

Para agregarlo, primero tienes que habilitar la parte de HTTP Binding. Para hacerlo te vas a servidor–> Configuracion del servidor->HTTP Binding y lo habilitas.

El segundo paso es detener el servicio de openfire.

Despues, en windows (hay que ver en linux en que ruta seria), te vas a la ruta de C:\Program Files\openfire\plugins, ahi pegas el archivo redfire.war e inicias de nuevo el openfire y en automatico se carga el pluging.

En la pagina de administracion de openfire, de hecho te va a aparecer un nuevo menu que dice redfire, eso quiere decir que s instalo correctamente.

Para validarlo entras a la siguiente ruta desde el navegador http://my_server:7070/redfire y te debe de abrir una pagina, si te la habre ya estas del otro lado, porque lo siguiete es lo mas facil.

En esa pagina que abriste, hasta abajo viene la opcion para descargar el pluging para el spark. En windows hay que irnos a C:\Program Files\spark\plugins y ahi lo guardas. En automatico cuando arranque el spark va a cargar este nuevo plugin y en las ventanas de chat te debe de aparecer un 5 encerrado en un circulo, eso quiere decir que se cargo correctamente el plugin, y listo eso seria todo para poder tener el video chat, presionas ese boton y al otro usuario le va a llagar la invitacion para que la acepte siempre y cuando tenga tambien el plugin el spark, porque si no le va a llegar un link para hacer el video a travez del navegador.

Para el audio chat, lo que hice fue descargar un plugin para el spark, en el servidor ya no hay que hacer nada. El pluging lo descargas desde http://code.google.com/p/jitsi-jingle/downloads/list

Para que funcione este plugin tienes que eliminar el anterior ino que se llama jingle.jar Este pluging se encuentra en dos carpetas la primer ruta es en C:\Program Files\spark\plugins de ahi lo borras y ahi mismo dejas el que acabas de descargar. la otra carpeta es c:\documents and settings\mi usuario\datos de programa\spark\pluging ahi hay una carpeta que se llama jingle y el jingle.jar las borras y listo. inicias el spark y ahora tambien a lado del 5 te va a aparecer un telefono, que es el que se usa para el puro audio.

Espero te sirva de algo

Tengo instalado Openfire (v 3.8.2 )/spark(v2.6.3) con el plugin Redfire. La comunicacion funciona bien (video y audio), pero cuando se utiliza el chat, spark se bloquea y no responde (ninguna de las ventanas) no me queda otra, que cerrarlo con el Task manager de Windows. Esto sucede, a todos los usuarios que discuten. En los foros no encontré solución al problema. ¿ tienen vosotros el mismo problema ? En lo afirmativo, han encontrado una solucion ?

Que tal Baston

A mi me paso esto al principio y me di cuenta que es porque el spark cuando tu mandas una invitacion de video chat, manda una liga, por ej. http://my_server:7070/redfire/video/redfire_2way… Si tus equipos no estan resolviendo por DNS correctamente el nombre my_server es cuando se queda bloqueado el spark, porque como que se queda esperando encontrar o que le resuelva este equipo.

Lo que tienes que hacer es validar que te este resolviendo la ip de tu servidor correctamente. Esto lo puedes hacer tirando un ping a tu servidor y validando que resuelva la ip de tu servidor, si no te responde, muy probablemente tienes que agregar ese nombre a tu servicio de dns o en su defecto modificar el archivo host para hacer que apunte hacia la ip correcta.

Solo se me paso especificar bien, lo que te tiene que resolver correctamente es el dominio que configuraste en tu openfire, por que ese es el que busca.

Por ejemplo, si el equipo donde intalaste el openfire se llama server-im.mydominio.com y cuando intalaste el openfire le diste el dominio mychat.

Desde el spark cuando mandas la invitacion de video lo que mandas es http://mychat:7070/redfire/video/redfire_2way

Aqui es donde te decia que lo que te tiene que resolver correctamente es la parte de mychat. Si tu le das un ping a server-im.mydominio.com supongamos que te resuelve la ip 192.168.1.10. Si tu le das un ping a mychat, te debe de resolver esa misma ip, eso es lo que tienes que validar.

Hola Herbert, gracias de antemano. Tengo tres preguntas:

  1. que pasa si NO instalo el redfire y lo único que hago es instalar el plugin jitsi-jingle en el spark como me dijiste, lo cual hice, debería funcionar? porque lo hice, me da para llamar y contestar pero no me da voz y en menos de 20 segundos se finaliza la llamada
  2. Debo configurar o mapear algún servidor asterisk para que me funcione el audio en los chat?
  3. Actualmente virtualize la IP de mi servidor de chat y video conferencias y la publiqué través de tres puertos en mi firewall: 9090 para administrar el openfire, 5222 para chatear y 3306 para administrar unas bases de datos mysql. Me hace falta abrir algún otro puerto?

Muchas gracias por tus respuestas

Mira, la verdad no se si funcione sin el redfire. En mi caso tengo el redfire y me funciona sin problemas. No estaria de mas que instalaras el plugin y ver si con eso funciona.

Yo creo que si es necesario ya que por lo que he visto, el redfire es el que hace como que la conexion con el openfire para administrar las sesiones.

Tengo una duda, como haces tus videoconferencias, si no tienes el redfire?, utilizas alguna otra aplicacion?

Para lo de los puertos, el redfire usa el 1935

Hola Heber, te cuento que me puse a leer mucho sobre este tema, es como dices. ya pude instalar el redfire, mañana jueves lo estaré probando. Actualmente uso skype y sistemas como el citrix, pero queremos alo nuestro, sobre todo para la parte de compartir pantallas, con el big blue button

Todas estas herramientas son buenas y queremos centralizar la telefonía IP, video chat, correo y conferencias en un solo sistema. Por el momento par ña telefonia usamos ELASTIX, en otro servidor virtualel videochat y en otro el bigbluebutton, la idea es tener el video chat (openfire) con el ELASTIX, pero debo primero testear el funcionamiento de la telefonía.

Gracias por todo, mañana te cuento como me fué con esto

Hola Hebert, ya configuré todo y me funciona desde la página los demos. No se como corregir lo del dominio, te cuento: hay varias ciudades, bogota, medellin, cali, etc. En bogotá están los servidores de la empresa y tenemos un dominio llamado corporativo. ademas de este servidor poseemos varios servidores mas, dentro de los que se encuentra uno llamado SRVVIDEOCHAT en ubuntu, este tiene el openfire y me funciona el chat y todo, publique la ip local para poder entrar desde fuera de la empresa y desde los celulares. Con el chat no hay problema, pero con el redfire, cuando mando la invitacion, me envía el nombre del servidor, SRVVIDEOCHAT y si estoy fuera de la empresa obvio no lo encintrará, debería enviarle en vez de ese nombre, la IP pública para que pudiera abrir el servicio, como puedo arreglar esto,

Gracias

A mi me pasa lo mismo jejeje

Encontre una parte donde menciona que se debe de modificar el archivo red5.properties El archivo lo encontre en la siguiente ruta (en un windows 7) c:\users\miusuario\appdata\roaming\spark\plugins\redfire-plugin

Este archivo esta asi

#Red5 Settings

server=btg199251

port=7443

popup=true

protocol=https://

Revisando encontre que si se modifica el dato de server, en este caso poniendo tu ip publica, deberia de mandar las invitaciones ya con ese valor

Yo hice el cambio y no me funciono, pero encontre en los logs del spark que busca este archivo en la siguiente ruta c:\users\miusuario\spark como esa ruta no existe por eso no me tomaba el cambio. lo que hice fue crear esta nueva carpeta y pegue ahi el archivo con el dato modificado y voala, ya la manda con ese dato

El detalle es que aun no puedo hacer que se vea el video desde internet, no se si me haga falta abrir algun puerto, porque ya abri el puerto 7070 (puerto del http binding del openfire), 7443 (puerto https del binding) y el 1935 que es el de audio y video pero no me funciona

Has la prueba y me dices si te funciona. Mientras sigo buscando si hace falta algun otro puerto.

que tal baston, si lo pudiste hacer funcionar?

Heber hola, ya pude hacer que se viera por internet desde cualquier ubicación; fue simplemente abrir los puertos 80 y 443 (http y https) y también el que dices, el 1935, la verdad creo que nonecesitamosel 1935.

Mi compañero se pudo conectar conmigo en video conferencia a través de la IP publica los dos, no usamos nada local. Lo del puerto 443 y 80 es porque lei en un artículo que este protocolo se encapsulaba a través de los puertos http y https, algo asi, entonces es como si realmente usaras esos puertos para trabajar esta conexión.

El otro punto del que nos hablaste de cambiar IP en una ruta del equipo, lo que yo hice fué diferente, abrí la cnsola de openfire y en nombre servidor coloque mi IP publica, la IP con la que mapee mi IP local y reinicié los servicios. Todos los contactos trabajan bn, notará que se te duplican pero es normal y porque unos tendrán el jid del nombre del servidor y otros el de la IP (por ejemplo jnorena@srvvideochat y jnorena@190.x.x.x), pero se arregla reiniciando el spark, el solito corrige eso. Otra cosa que debes tener en cuenta es conectarte a la base de datos de openfire y en una tabla llamada ofpropiedad, no recuerdo bien el nombre, el primer renglon trae los jid autorizados para entrar a la consola de administracion, verás que tienes por ejemplo jnorena@srvvideochat, pero debe editarlo por base de datos y colocar jnorena@190.x.x.x y ya puedes de nuevo entrar a la consola de administración. Con esto cada que te conectes, toda invitacion se enviará con el nombre del servidor, esa es la liga que toma el spark

Seguiré mirando porque mi equipo se medio bloquea, mañana te cuento como me terminó de ir

Nos vemos

Perfecto!!!

Yo habia pensado en hacer ese cambio, pero tenia el temor de que mis usuarios no se pudieran conectar o que no los validara correctamente el openfire, ademas de que tengo instalado la parte del fastpath y webchat y como ya esta en produccion no me animaba a moverle.

Que bueno que hayaste esta otra alternativa y voy a hacer la prueba de publicar los puertos que mencionas para probarlo a travez del internet.

Hago las pruebas y te comento como me fue.

Recuerda que una vez hecho esto, antes de reiniciar te conectas a tu base de datos openfire, abres la tabla ofProperty y en el campo name identificas donde su valor es admin.authorizedJIDs, que siempre es el primer renglón, una vez identificado, te pasas al campo propValue del mismo renglón y te aparecen los JIDs autorizados para administrar la consola del openfire, en mi caso, el administrador eran admin y jnorena y aparecían como admin@srvvideochat, jnorena@srvvideochat, debes cambiarlos por admin@190.x.x.x y lo mismo con los usuarios que sean administradores, por lo general es uno ó dos, los que tu hayas puesto te aparecerán ahí. aplicas los cambios y reinicias el openfire, yo reinicie la máquina y listo, ahora si puedes entrar de nuevo a tu consola openfire. Saca unacopia antes de y me imagino que esto lo haras en dia no laborable para evitar cualquier traspies en la comunicación de los usuarios.

No solo escribopor esto, tengo en mi equipo un problema con flasplayer, siempre que hago la video conferencia yo me bloqueo, a nadie la pasa, no se como arreglar, reinstalaré el spark

Buena Tarde Juan!!

Leyendo la discucion, veo que tienes experiencia en la instalacion y puesta en marcha del Servidor Openfire y Spark, me gustaria y si esta en tus posibilidades me echaras una mano. Ya he instalado Openfire, y Mysql en Centos. pero tengo inconvenientes en el nombre de Dominio. Ya que he colocado la ip local del equipo y no conecta el spark. No se si las reglas del iptables estaran bien configuradas. Tambien he probado colocando la Ip publica de mi red, pero no ha funcionado. Que debo hacer?? Te agradezco una Ayuda!!

Hola como hago para poder usar la funcionalidad de chat en voz en el spark uso la version 2.8.3

alguien me puede ayudar a configurar openfire con mi IP publica. soy principiante en esto. en red local me funciona pero en red externa no. paso a paso alguien que me diga como hacerlo por favor