powered by Jive Software

Client cannot connect to openfire server

Hi there,

I installed openfire on centOS the installation was successfull without any errors. However clients like spark or jabber cannot seems to find the server. I can ping the Ipaddress. I have disabled the firewall in the client machine. I have opened 5222,5223,9090,9091 ports, but still clients cannot find openfire server.

Here is the SS with the server setting:

Thanks.

You probably don’t want your xmpp server to be called “localhost.localdomain”. You can change this in the System Properties (xmpp.domain) or rerunning the web setup (Domain field).

What are you putting into Server part in Spark? IP should still work, though it is better to use server’s domain name. But then this name should be resolvable on the network (DNS). Or you can press Advanced in Spark’s login window and uncheck Automatic host and port discovery, put IP address there. Then you can use domain name in the Server field without that name actually being in your DNS (Spark will link that name with the IP you specified in the Advanced settings). If this still doesn’t work, try disabling the firewall on the server.