powered by Jive Software

Client cant not connect to server

Hello,My boss want my company to have a chat server for work to be able to commucate well we have a public ip and a domain name for the company.i created a subdomain chat.mydomain.com and i created port forwarding in my router .but i cant not connect user to the openfire server.DId i do something wrong somewhere.I need you help

Thanks

kafui

Openfire version? If not Openfire, what server?

Spark version?

What error exactly Spark shows?

What is your Openfire server’s “Server Name:” which is shown on the first page of Admin Console?

Thanks for your reply ,

1.My openfire version is 4.0.3 and the spark version is 2.8.1 …

2.My open server name is the name of the subdomain i created from Public DNS (chat.mydomain.com) and the ip point to my public ip .we have a domian name from namecheap.com

3.The name at host name section is server-pc. that is the name of the server when install the server which runs windows 2008 r2

4.I have done port foward from my internatl router for 5222 and 5223 to point to the internal server Ip

5.i have enable firewall for 5222 and 5223

hope you can help me

You haven’t answered this, which is the most important thing:

What error exactly Spark shows?

You don’t need port 5223, this is an old port and it is not used anymore.

When you login in Spark, do you put chat.mydomain.com into its Domain field?

1.When i put chat.mydomain.com at the domain field the error i get is ( Unknown connection error ,please review the logs for more information

2.When i put chat.mydomain at the domian field the error, i get is ( can’t connect to server invalid name or server not reachable

  1. Whenn i put the my public ip in the domain field the error i get is ( Unknown connection error.Please review the logs for more information

Putting chat.domain won’t work as this is a not correct address

Unknown error usually shows that something is wrong with the server. It can find the domain, but can’t connect to the server. Maybe your firewall is still blocking something or your port forwarding rule is not working. Anyway, this is not Spark’s fault in this case.

You can also check logs for more information C:\Users\User\AppData\Roaming\Spark\logs

what is the best address is should put there? because chat.mydomain is the subdomain i created for the from my domain name i bought from namecheap and i created an SVR to point to my public IP router.

No difference. You should decide yourself what is more convenient to your organization and users. Some want to separate their chat server as a separate domain (subdomain.domain.com), some prefer to use the main domain. You can even have you server as chat.domain.com and your users logging in using just domain.com, if you setup xmpp SRV reconds like that Check DNS SRV records for XMPP

So when i login to igniterealtime.org it redirects my connection to xmpp.igniterealtime.org automatically (that’s the server’s real name).

It seam i have done everything correct i have disable the firewall but i still get error unknown connection .Do you i need to change the hostname to match the domain?

when i use the internal ip of the server 192.168.1.78 it connect .what may be making it difficult if i use the public ip n domian name it not connecting

No, hostname is not important. As i’ve said on the private message. post your Spark log here (replacing your real domain name with “domain.com”). I can’t say what is wrong though. Seems that Spark can’t get through to your server for some reason.

I have faced the same type of issue i.e not able to connect to server. I have just given the permissions in firewall for Spark on Client system and it’s done. I hope this might help some people. Thanks…

are you able to connect using local ip address?