Client Control Plugin Problems

I have Openfire 3.5.1 working very nicely on a Windows 2003 server, with a SQL DB & using AD for authentication.

I’ve just added the newly released client-control plugin & this doesn’t work so well. All My users get bugged to upgrade, but nothing happens if they click yes. if you use the link provided by the Client Control Plugin, you have to log into the admin console, which obviously most users can’t do.

From looking, I suspect I need to to add something to the web.xml to exclude /plugins/clientcontrol/getspark from the authenticator Am I on the right track?

I suspect this same problem is going to stop my fastpath webchat from working as well.


To prevent an the issue regarding spark notifications for upgrades, if you place an older version than the one deploy on the server notifications will not occur.

The other error I am not so sure about (bad web address). Unless your users are admins of their computers the upgrade is not possible either.

I can see how that would work, as would just removing the latest versions. I had hoped to move everyone to the latest version of Spark using this plugin rather than bugging them into submission.

For the error I think I need to elaborate a bit. I can reproduce the error myself, by not logging into the admin console & browsing to the getspark url (http://youropenfireserver/plugins/clientcontrol/getspark?os=windows) There’s no way to access this url without being an Openfire Admin (nothing to do with admin on their machine), which kinda limits the usefulness of this plugin.

I really wanted this plugin to work, so I’m a little disappointed right now. The other plugins are ace & I don’t really know enough about Java config files, other than guessing my way through them to edit the config.


Hey Simon,

Thanks for the bug report. I just released a new version of the plugin that solves the authentication request and some other reported issues.


– Gato

Hey, Gato. Maybe you want to take a look at my thread about Client control plugin? There are some other issues. Some are Spark related, but some are plugin related. Also there are some feature requests and questions in that thread. maybe a developer should shed a bit of light on that topic

Thanks for the quick repsonse on this.

I finally scheduled in a restart of the server, removed the old plugin, added the new one & but it appears to still be requiring authentication.

hmm. Now I don’t know enough about Java web.xml files, but thought I might be able to add the /plugins/clientcontrol/getspark url to the exclude element in the web.xml in the admin plugin. It seems a bit of a hack, but could it work?


Well that hack worked. At least I can advise my users of where to get the client from. I ahd hoped that would fix things but alas, no.

I’m not sure that it’s OpenFire’s fault - I think it’s probably Spark’s fault, but everytime Spark starts up you get message advising of the new version & that you need to restart your client to install it. Clicking Yes only succeeds in shutting Spark down. Next time exactly the same thing.

I guess it’s time to give up on the plugin & upgrade everyone by hand. Thanks for your help so far.


I’m also having this problem. I tried adding the URL to the web.xml file located in my adamin\webapp\WEB-INF folder but that didn’t work either. I’ve only been using Openfire for a couple of days now, but this seems to be the main sticking point for me. It would be great if I can get this part working as then the users can download the client for our roll out. Any help is appreciated. Thanks!


dombiak_gaston wrote:

Hey Simon,

Thanks for the bug report. I just released a new version of the plugin that solves the authentication request and some other reported issues.


  • Gato

How does the new version fix the authentication issue? I have the latest version and still need to authenticate to grab the spark client.

I removed the jar file from /var/lib/openfire/plugins restarted the whole server, then installed the clientcontrol plugin. It still goes to the authentication page of the Openfire server. Maybe the ‘fixed version’ isn’t updating some config file somewhere.

nothing on this issue? I really want to be able to have clients download from the openfire server (without authentication).

Even if the link is fixed to work without authentication, that does not change the fact that non-admins in windows cannot install spark. I use this purely to disable the notifications for this reason.

Well, in my envirnoment most users are local admins. (only those who abuse it or do not have the common sense are non-admins)

The problem I had & I think what Modulok is getting too is nothing to do with actually installing Spark. It’s to do with accessing the spark download url as displayed in the Client Control Manager. It’s still protected & you need to be a OpenFire admin to access the url.

My fix was to open the following file:

<OpenFire Install folder>\plugins\admin\WEB-INF\web.xml

This is the config file for the whole OpenFire admin website. Near the top should be the following:







login.jsp,index.jsp?logout=true,setup/index.jsp,setup/setup-,.gif,.png,error-se rverdown.jsp,/plugins/clientcontrol/getspark




You can see I’ve added the clientcontrol download url to the end of the list of excluded urls. This prevents the OpenFire web app checking to see if you’re authenticated (ie an Admin) when you use the ClientControl client download url.

Now I’m sure there must be a better way of doing this, that keeps the plugin configs seperate from each other, but I’m pushing the edge of my knowledge of Java here. I do know the above worked after I applied it to our live environment.

I hope that helps.


Simon, too bad you weren’t in last week’s group chat, David gave me a link to the newest (not on the plugins page yet) version of the client control plugin (v1.0.2). I am not sure if it’s still on the site he gave me, or if he would want it posted here. It does fix the auth issue, and I haven’t had any issues with it.

Any news on the release of v1.0.2 of the plugin? I’m going to try the “hack” above but a new plugin would be nice.


Search the forums for client control 1.0.2 and you should find the link for the somewhat beta download.

Devs: I thought it was going to be updated on the plugins page. Did someone forget?

Michael Fiss

Thanks - but it looks like it’s been removed from Jadestorm’s site, if that’s where you got it from originally…

Anyone fancy PM-ing me with the .jar? Or maybe we can get the plugins page updated if the new version has been cleared as ok?


Oh ok, two weeks ago someone asked me to PM it, but then he found the download. PM me your email and I will send it over, as I could not PM it.

Michael Fiss

Cool, thanks - PM on its way.

v1.0.2 is now available via the plugins page.