powered by Jive Software

Client Session how to make offline?

Hello.

i connect to Openfire with PHP on my web site.

Some users do not go offline. They are always stay online.

if there is no “event” for 10 minutes how can i close session ? i want to make offline. Openfire is not doing auto.

Thanks in advance.

More detailed:

System connect users via PHP Bosh client, then give their sid to strophe and continue with this.

Some of the connections can not be dropped by openfire.

Openfire preferences relatad with idle times are above:

xmpp.httpbind.client.idle 5

xmpp.httpbind.client.requests.polling 0

xmpp.httpbind.client.requests.wait 10

xmpp.server.socket.active false

xmpp.session.conflict-limit 0

xmpp.socket.ssl.active true

Currently i am not using any connection managers. But i will start to use connection managers so what will these values must be for dropping connections that don’t make any request to bosh for nearly 30 seconds.

Thanks in advance.

Hi,

do not drop online client connections.

The clients may have an autoconnect feature which may lead to a very high server load.

The clients may be tweaked to send useless messages every 25 seconds to keep the connection open in any case, even if you set the the timeout to 30 seconds.

Setting the timeout to a very low value may affect friendly clients which.

LG

Hi LG.

first of all, thank you for your response.

let me explain the problem more detailed.

I am using MUC feature heavily with strophe. Sometimes, i close browser and stop sending messages to server, but active connections remains active on openfire admin panel.

I see 1000+ online users, but when i restart the server, the number drops to 100s. (Our system is set to auto-connect even if drops.) So any -real- users connect again, and stalled connections drop. So, i am sure that these connections are not really connected… They are clients their browsers are just closed…

because of the so much stalled connections, openfire memory usage goes high up to 7-8 GB in one day.

I have to find a way to prevent it because i have to restart the server once a day…

Is there a parameter to set for dropping stalled connections after some time, or any workaround to get rid of that problem?

I have written our active parameters on openfire above, also using Openarchive and userservice plugins only…

Thanks in advance.

any suggestions yet?

It is now a very big problem for us.

Please advise something or i have to use a server with 65 gb’s of ram and have to restart it once in 3 days…