powered by Jive Software

Clients cannot connect to the Openfire Server remotely

Hi,

I installed Openfire 3.6.4 on my PC. I tried couple of XMPP clients both Java/J2ME(Midlets) and everything seems to be fine when I run everyone on the same PC.

But, when I try the same clients from a different PC (intranet PC), they wont connect. The exception is "Connection Refused.

I am using basic socket connection for J2ME client and for Java client I am using SmacK API without any Configuration object passed to the XMPPConnection class.

Interestingly the admin console listening at http://:9090 doesnt respond as well from another PC.

As for the ports, I think they are all fine coz I can access Tomcat/Weblogic’s admin console from a different PC.

Also, I tried a basic Server-Client socket example from different Pcs using ports 5222 and 9090, the example works fine.This was just plain old socket examples.

Obviously I am missing something basic here. Can someone please provide solution and throw in some ideas as to how ot resolve this?

Thanks in advance.

PS: I have attached the image with my server details.

What if you use IP-address:9090 ? The same with the clients connection. Also check if you are able to at least ping that computer by its name. Probably others cant see it by its name.

Ofcourse I tried with http://IP:9090, no luck.

Are you able to ping that IP? Can it be some firewall issue?

yes I can, in fact I even turned off the firewall and tried a simple Server-Socket example on ports 9090 and 5222. Both of them worked with no problems whatsoever from 2 dffierent PCs.

I am surprised no one didnt face this issue.

Time to time someone will face something similar, but usually users dont have such problems. I think this has to be network/firewall issue. But im out of ideas now.

hi,

got a similar problem during implementation of an xmpp client using smack for android.

when i tried to connect to openfire, always got ‘connection refused’ (don’t remember the complete error message) while the same code worked without any problems running in a standard jvm.

solution for this problem was to use a ConnectionConfiguration and disable SASLAuthentification because the Android Runtime doesn’t support SASL…

ConnectionConfiguration conf = new ConnectionConfiguration(“example.com”, 5222);
conf.setSASLAuthenticationEnabled(false);
this.m_connection = new XMPPConnection(conf);

maybe this will help u.

otherwise u could post some more information (complete message u get from the server when trying to connect and server logs)

greez

no, it didnt work either. Thanks though.

could u please post the complete error messages from server and client so that we’ll can look for other problems …

Hi

it seems I have exactly the same problem you had.

Any luck in the meantime?

thanks

cheers.

OK I found that my hosting provider is closing all non-web ports…

so 9090 is closed.

regards,

c.

same problem, any solved ???