powered by Jive Software

Conexión Servidor a servidor


#1

Porque la conexion servidor a servidor no se realiza?,instale la ultima version y no funciona,unos amigos me dijeron que en la 4.1.4 o inferior si funciona,no entiendo el porque si se supone que las actualizaciones de en este caso openfire es para corregir errores y no quitarle funcionalidad,si alguien me puede ayudar con una version que funcione la conexion servidor a servidor como por ejemplo la 4.1.4 segun me dices que me conectacte por telegram @R34L1V3, gracias de antemano


#2

Nobody can answer “Why it is not working?” without providing any information (logs, errors, setup details). Server to server wasn’t removed from new versions and it works for others.

You can find older versions here https://github.com/igniterealtime/Openfire/releases


#3

bueno,los detalles de mi configuracion es que tengo un servidor en el ip 10.28.107.229/27 y el otro esta en el rango 10.28.107.5/27,los dos responden paquetes de ping por estar en redes distintas con un router intermedio RB750Gr3,los puertos 5269 estan abiertos y al dar ping a sus respectivos dns tambien se optiene respuesta,lo que no sucede es que ambos en la version 4.2.1 no se enlazan,probare con la 4.1.4,si tengo exito lo informare,gracias por ofrecerme las versiones anteriores para probar


#4

While you are trying, how do you determine that it is not working? Have you tried to add a user from another server in a client and send a message? Server to server connection is only established when there a user tries to connect to another user. It is not established automatically without it. Also, have you added each server to their whitelists on each server (Server to server menu)?


#5

si la opcion de la lista blanca la realice,incluso lo deje en que cualquier servidor se puede conectar a mi servidor,ambos los configure asi para probar,lo que no hice fue añadir un usuario de un servidor al otro y enviar un mensaje,creo que seria muy bueno agregarle una funcionalidad que compruebe si se establece el enlace servidor a servidor,por ejemplo como la comprobacion al configurar el ldap al instalar openfire,voy a probar añadir un usuario al otro a ver si se establece el enlace


#6

probe añadir a un usuario del otro servidor y nada,

2018.12.22 11:59:57 WARN [pool-47-thread-1]: org.jivesoftware.openfire.session.LocalOutgoingServerSession[Create outgoing session for: ldap.cosmos.cu to jabber.cosmos.cu] - Unable to create a new session: Dialback (as a fallback) failed.
2018.12.22 11:59:57 WARN [pool-47-thread-1]: org.jivesoftware.openfire.session.LocalOutgoingServerSession[Authenticate local domain: ‘ldap.cosmos.cu’ to remote domain: ‘jabber.cosmos.cu’] - Unable to authenticate: Fail to create new session.
2018.12.22 11:59:57 WARN [Server SR - 25907377]: org.jivesoftware.openfire.net.SocketReadingMode - TLS requested by initiator when TLS was never offered by server. Closing connection : org.jivesoftware.openfire.net.SocketConnection@1bdf2a1 socket: Socket[addr=/10.28.107.225,port=35092,localport=5269] session: org.jivesoftware.openfire.session.LocalIncomingServerSession@441534 status: -1 address: ldap.cosmos.cu/788heie47k id: 788heie47k


#7

Well, my knowledge about S2S ends here. Can’t tell what these errors mean. Both servers have to have TLS enabled and proper certificates (i think that self-signed certificates might not work).

I’m not a developer, so i can’t say why there is no test connection option. I just know that S2S only establishes when it is actually used.


#8

bueno al final logre enlazarlos,el lio estaba en los certificados autofirmados que los tenia habilitados,me llegan los mensajes pero me pone al usuario como no autorizado,como que no esta conectado,al menos es un logro,pero me gustaria que funcionara al 100,yo uso el pidgin,sabes que pudiera ser?