powered by Jive Software

Conference.domain.tld not working

Hello

I’‘ve got the following problem. I installed a Wildfire 2.6.2 Server on my root machine (after testing on a host @ home). Everything is quite working fine, but the goupchat doesn’'t do what i want to.

When i connect through my server with an account on my server i am able to use the conference with any room i want.

When i connect through the conference.domain.tld with an other account (i.e. a jabber.org JID) i’'m not able to use the conference ability. Im alway rejected with no reason given.

I used PSI to connect to my Server with the different accounts (my own account on my server an an other). I also tried an other client with the same effect. Always rejected with no reason given.

I don’‘t know why ist works with my account and doesn’’ with other accounts.I’‘m not able to invite other jabber users, as they don’'t have an account on my server.

Hope u understand my Problem (guess my english isn’'t that well, but i keep on learning)

Thankfully

Magath

Hey Magath,

If I understand correctly the problem what you are seeing is a server-2-server configuration problem. The fact that local users can make use of the local conference (aka MUC) service means that you are on the right track.

When you log in to a remote user (e.g. jabber.org) and try to join a room in your local server then jabber.org will need to find your remote server to try to use the conference service. That means that you will need to properly configure your DNS server and create SRV records for your server and the conference service. The other thing you will need to check out is that port 5269 is not being blocked by a firewall. And finally, your server needs to be somehow accessible from the internet.

You can enable the debug log to see how server-2-server connections are doing.

Regards,

– Gato

Hi

Thanks for your help. I’‘m kind of stupid. I forgot to set up the SRV records in the DNS. So the local Users were able to use it, but the other servers didn’'tknow about the services running “behind” conference.domain.tld.

Now I was setting up the records, waited a bit for the NS to replicate the record and “wohoo” it is working.

So tanks again for your help.

Greetings

Magath