powered by Jive Software

Conference rooms keep disapearing wildfired 2.4.4 linux distro

conference rooms keep disapearing wildfired 2.4.4 linux distro

dont know what more to explain here create a room called admins_montreal_whatever and it stays around for a while then I come back and its gone…

I would really like to fix this

we use a my sql backend if that makes a diff

cliff29

I have installed wildfire 2.4.3 on gentoo netboot and I don’'t have any problem like you do. Can you please post error, warn, info debug log? Which linux distro are you using?

Regards,

wmhtet

Sorry should have mentioned that redhat fedora FC4-i386-disc1.iso and we use mysql… I am not a linux admin and I am not sure what logs you are refering to but if you tell me where to get what I can manage… I looked in the wildfire admin console and this is all there was in the logs well the end anyways. dont think that is what you are looking for.

2006.02.15 23:49:46 [org.jivesoftware.wildfire.roster.Roster.(Roster.java:147)] Groups () include non-existent username (jcheng)

2006.02.15 23:49:46 [org.jivesoftware.wildfire.roster.Roster.(Roster.java:147)] Groups () include non-existent username (zacharyk)

2006.02.15 23:50:34 org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:159) Connection closed before session established

Socket[addr=/10.25.13.15,port=53824,localport=5222

oh sorry should have mentioned that when i go to recreate a room with the same name it says it already exists and then it shows up again for a while and disapears when i go and look again

cliff29

The logs are in the admin console:

Server->Server Manager->Logs

There you will see tabs: error, warn, info and debug, which you need to enable.

Regards,

wmhtet

Cool good place to start…

Can you explain these and maybe It will help me to cleanup a little to track down whats wrong

2006.02.15 23:49:46 [org.jivesoftware.wildfire.roster.Roster.(Roster.java:147)] Groups () include non-existent username (martint)

2006.02.15 12:08:22 There is a group property whose value is null of Group: IT_MANAGER

this is the full debug i just enabled it

2006.02.16 00:19:05 Connect Socket[addr=/10.25.13.16,port=34116,localport=5222]

2006.02.16 00:19:05 Error creating session

java.io.EOFException: input contained no data

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2982)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1410)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:331)

at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)

at org.jivesoftware.wildfire.net.SocketReader.createSession(SocketReader.java:572)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:110)

at java.lang.Thread.run(Unknown Source)

2006.02.16 00:20:44 Connect Socket[addr=/10.25.13.15,port=40065,localport=5222]

2006.02.16 00:20:44 Error creating session

java.io.EOFException: input contained no data

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2982)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1410)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:331)

at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)

at org.jivesoftware.wildfire.net.SocketReader.createSession(SocketReader.java:572)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:110)

at java.lang.Thread.run(Unknown Source)

2006.02.16 00:24:08 Connect Socket[addr=/10.25.13.16,port=51110,localport=5222]

2006.02.16 00:24:08 Error creating session

java.io.EOFException: input contained no data

at org.xmlpull.mxp1.MXParser.fillBuf(MXParser.java:2982)

at org.xmlpull.mxp1.MXParser.more(MXParser.java:3025)

at org.xmlpull.mxp1.MXParser.parseProlog(MXParser.java:1410)

at org.jivesoftware.wildfire.net.MXParser.nextImpl(MXParser.java:331)

at org.xmlpull.mxp1.MXParser.next(MXParser.java:1093)

at org.jivesoftware.wildfire.net.SocketReader.createSession(SocketReader.java:572)

at org.jivesoftware.wildfire.net.SocketReader.run(SocketReader.java:110)

at java.lang.Thread.run(Unknown Source)


Cant see anything like your group xyz disapeared because lol… ideas?

got debugging enabled and i have recreated a room. here is the error i get on the group chat page

Error creating the room. A room with the request ID already exists.

And now i go back and the room is there… as always but wasnt availabe to use before its like its hiding somewhere in the DB lol

checked those logs again and dont see anything wrong with anything anywhere…

Hi,

Which database are you using. May there are problems with database permissions.

Mysql fellow admin set it up

Are they disapearing after a time of inactivity? After a certain amount of time a room “disapears” when it’‘s been inactive, although it’'s still in the database, I think its a day or so.

I’'ve got around this by having a bot visit the room once a day.

Hey guys,

The new version of Wildfire (coming out today) will unload from memory inactive/unused rooms after 30 days of inactivity. Unloaded rooms will still be available in the database so users will still be able to log into the room (the server will load it from the database). It is going to be possible to change the 30 limit day to any number of days by setting the system property xmpp.muc.unload.empty_days.

Hope that helps.

Regards,

– Gato

I think we might have corrupted the rooms when creating them directly in the DB we have deleted them all and when I get around to recreating them Ill see if they stick…

xmpp.muc.unload.empty_days.

i assume -1 will make them stay forever?