powered by Jive Software

Connecting to openfire on aws

hi I have setup openfire on the amazon cloud and can access the openfire admin console online. I cant however connect to the server using spark i get caant connect to server message.

i am not entirely sure what i should be using for the servername i have tried

http://ec2-174-129-59-57.compute-1.amazonaws.com

ec2-174-129-59-57.compute-1.amazonaws.com

as well as the hostname from the openfire console

domU-12-31-39-0F-7C-12

nothing seems to work. sorry if its a silly question but am a newb at this stuff

any help is appriciated

Hello,

You should be using ec2-174-129-59-57.compute-1.amazonaws.com the server name. Have you configured the security group that your instance is using to open up port 5222?

Hope that helps,

Ryan

It really sounds like connectivity issue, as Ryan is pointing out as well, not naming of the server. May be is is the case that location from where you are trying to connect to your server is blocking TCP/5222. Do simple test from where you are connecting using telnet (since we talking TCP) like below:

``

oiram@h4ck3r:~$ telnet ec2-174-129-59-57.compute-1.amazonaws.com 5222
Trying 174.129.59.57…
Connected to ec2-174-129-59-57.compute-1.amazonaws.com.
Escape character is ‘^]’.

I can see that it works for me. I was even able to create account on your server so installation is perfect. Although you have search service disabled so could not search for users.

What I have noticed that you have xmpp domain set for domU-12-31-39-0F-7C-12 and tat is probably causing some issues. Set it to ec2-174-129-59-57.compute-1.amazonaws.com and restart server, and let me know so I do some more testing.

Hi,

I am also having a somewhat related problem to the one above: I have installed the Openfire server on an Amazon EC2 server, and connot log into an existing account using a domain name I have.

Here is ** **what is working for me :

  1. Created an EC2 server with Public DNS : ec2-23-23-186-131.compute-1.amazonaws.com
  2. Setup the server name to be the above Public DNS.
  3. Setup the Group Policy of this server appropriately , opening XMPP ports etc.
  4. Installed Openfire server.
  5. Created an Openfire acount with name ‘gamersweb_qa1’ password ‘qa1’ on the Openfire server.
  6. I can successfully log to this account with Pandion with account name : gamersweb_qa1 @ec2-23-23-186-131.compute-1.amazonaws.com [password: qa1]

Here is what is not working for me :

I am trying to make use of the domain name I purchased : “2hermes.com” instead of the above long Amazon server name.

I did the following:

  1. Created an Elastic IP 23.23.186.131 on Amazon EC2 and associated it with this server.
  2. Pointed the A records of *.2hermes.com and @2hermes.com to the IP address above.
  3. Renamed the Openfire server name to “2hermes.com
  4. Recreated the Openfire server certificates
  5. Restarted the Openfire server
  6. Trying to connect with Pandion to ‘gamersweb_qa1@2hermes.com’ … this fails

I am suspicios of my step # 2 above … although going to www.2hermes.com:8080 works as expected. It reaches my Java server on this server / virtual machine [and then gets redirected, not to be confused].

I have reverted the server settings to “ec2-23-23-186-131.compute-1.amazonaws.com” so at this point @2hermes.com accounts shouldn’t be expected to work from Pandion.

I would most appreciate if anybody has an idea what I may have missed in the above settings and let me know … thank you,

Guy

Hi,

I believe the problem is that I missed setting up the SRV records. So I have setup the following SRV records:

Service
** Proto **
Name
Priority
**
Weight
** Port

** Target**

_xmpp-client
_tcp
amazonaws.com.
10
0
5222
ec2-23-23-186-131.compute-1.amazonaws.com.
_xmpp-server
_tcp
amazonaws.com.
10
0
5269
ec2-23-23-186-131.compute-1.amazonaws.com.

I still cannot connect with Pandion, probably due to a mistake in the above, or something additional.

If anybody knows more, please let us know.

Thank you,

Guy

Hi, If anybody finds it useful, I figured out the problem: in the SRV record, the Name needs to be my domain name (2hermes.com) , not amazonaws.com. Now it works …

Guy