powered by Jive Software

Connection manager & jwchat base openfire

i hava a question,want to help from everyone here.

resource:

server:openfire 3.6.4(192.168.18.10)

client:spark(192.168.18.11)

web client:jwchat(192.168.18.11)

connection manager& apache 2.2(192.168.18.11)

now,

server + client :ok

server + web client :ok

server + client +cm :ok

server + web client + client +cm: (client:ok)(web client:NG)

now form apache httpd.conf

      ProxyPass /http-bind/ [http://localhost:7070/http-bind/](http://localhost:7070/http-bind/)
      ProxyPass /http-poll/ [http://localhost:7070/http-poll/](http://localhost:7070/http-poll/)
      ProxyPass /JHB/ [http://localhost:7070/jhb/](http://localhost:7070/jhb/)

now from jwchat config.js

        name:"Native Binding",
        description:"Ejabberd's native HTTP Binding backend",
        httpbase:"/http-bind/",
        type:"binding",
        servers_allowed:[SITENAME]

name:“Native Polling”,
description:“Ejabberd’s native HTTP Polling backend”,
httpbase:"/http-poll/",
type:“polling”,
servers_allowed:[SITENAME]

now from cm manager.xml

    <domain>****</domain>
    <port>5262</port>
    <password>159632</password>
    <manager>
        <name>wan-jyhz</name>
        <connections>1</connections>
        <incoming>
            <threads>5</threads>
        </incoming>
    </manager>
    <server>
        <certificate>
            <verify>false</verify>
            <verify>
                <chain>true</chain>
                a third-party that we trust. -->
                <root>true</root>
                <validity>true</validity>
            </verify>
            <accept-selfsigned>false</accept-selfsigned>
        </certificate>
    </server>
    <client>
        <idle>1800000</idle>
    </client>
    <socket>
        <default>
            <active>true</active>
            <port>5222</port>
        </default>
        <ssl>
            <active>true</active>
            <port>5223</port>
            <storeType>jks</storeType>
        </ssl>
        <backlog>50</backlog>
        <buffer>
            <receive>-1</receive>
            <send>-1</send>
        </buffer>
        <linger>-1</linger>
    </socket>
    <processor>
    </processor>
    <httpbind>
        <enabled>false</enabled>
        <port>
            <plain>7070</plain>
            <secure>7443</secure>
        </port>

some adavice,wait,thanks