powered by Jive Software

Connection user from outside the firewall

HI, I’ve setup openfire on one of my Ubuntu boxes, inside our lan everything works fine.

Now I would like to connect clients from the outside.

The inner server name is like 10.0.0.204 so my users are something link username@10.0.0.204

Now, from the outside, my nat takes traffic from xxx.dynalias.com to 10.0.0.204:5269

Now the client can connect, nat logs are ok, but obviously I can’t login. I think the problem is that from outside the user looks like username@xxx.dynalias.com

How can I solve this issue without installing a different server for each external client?

thank you

5269 port? Are you using custom ports? Default would be 5222.

Also you can try changing server’s name to xxx.dynalias.com though this can bring some new problems with internal users.

Depends on a client also. Some clients let specify server and also a hostname (like Exodus). So when you specify IP as a server and a name as a hostname. Then client is identifying itself as username@servername. For external users you will have to do vice versa. Probably this can be done with Spark too.

changing the server hostname would be my last choice…isn’t there a way to config domain aliases on the server side? this would quickly solve any issue…

No, there is no domain aliases option. There is only xmpp.domain system property which is your Openfire server’s name. As i said this probably can be fixed on a client side. But i cant say for sure.

I can only give you the example of our setup. We had an Openfire server, and it’s name was like the machine’s hostname - jiveserver. But this hostname wasn’t in local DNS, so the clients had to login using IP address. We use Exodus. So in Exodus we were putting username@jiveserver in login field. And on the other tab there are host settings, they are retrieved automatically by default. There we were putting the IP address. So maybe in you case it is possible to do vice versa.