powered by Jive Software

Console is a blank screen

I have completed the installation of openfire (3.6.4), installed JRE, started the services and launched from windows start menu. The openfire console screen opens, the “listening on port :9090” completes and I end up with a blank screen. Anyone have an idea of what I have done wrong?

By using the FGDN I am able to get to the console. Ans provided by one of the threads. Many Thanks.

“FQDN” - could have been more helpful. It still took me 15 minutes to figure that out…

What he means, folks, is Fully Qualified Domain Name and for you guys trying the “Launch Admin” Button the domain name is wrong: http://127.0.0.1:9090/index.html (incorrect) should be http://localhost:9090/index.html

Openfire Devs, please fix this bug.

It works fine for me on the same machine while using 127.0.0.1 IP address.

After some more research, I found someone claiming that it was a DNS issue. It may be the case that a default Server 2003 machine can’t properly map the name localhost to 127.0.0.1. My server is a new install and is still mostly default Windows S2K3 SP2.

If you search the web, you will see that a lot of people have spent a lot of time tying to figure out why they get a blank admin screen. A lot of advice is leading folks to think it has to do with SSL certificates so I tried an experiment where I deleted all my SSL keys and I can still access the Admin panel; when I type the “localhost” URL instead of pressing the “Launch Admin” button. That button is costing folks time and effort chasing a problem that should be fixed if not in the program, at least in the documentation.

Cordially,

A.D. Pro

ARGold wrote:

It may be the case that a default Server 2003 machine can’t properly map the name localhost to 127.0.0.1.

If that was the problem, then you won’t be able to ope Admin Console by using localhost. Because it has to map to 127.0.0.1. Maybe you ment the oppozite. But that sounds strange. As console says that it is listening on 127.0.0.1, so it should load the admin screen.

So, i’m still not sure that the problem is in the launcher. I will have to setup a virtual machine with WS2003 to test this. MS says that the hosts file should look the same on XP and WS2003, so i assume it should work the same.

So, i have setup a virtual machine and as i was thinking, this is not a launcher fault, but a result of Internet Explorer’s Enhanced Security mode. You can’t see content of 127.0.0.1 until you add this address to Trusted Sites list. Then it’s fine

ws2003-of-trust.jpg

Actually, i think most of the WS admins should know about that, as you cant open any site (not belonging to MS) without adding it to Trusted Sites, even intranet sites I’m reading these forums almost every day and i can’t remember that there were many complaints about that. Anyway, i have updated OF-47 (http://www.igniterealtime.org/issues/browse/OF-47) with an additional comment about that. Thanks for your insight

Yep, that worked for me - Adding it to trusted sites. Thanks Wroot

Wow, if you can’t trust 127.0.0.1, who can you trust?

Anyway, thanks for getting to the bottom of that. I hope to see that added to the install documentation. I "Have found folks with that problem and there is some bogus advice out there.

Cordially,

ARGold