powered by Jive Software

Contact list sharing not working 3.8.2

Long time listener, first time caller…

I recently rebuilt our openfire server on a centos6.4 box. Everything is working properly with our AD sync, and I have pulled in the groups. I have an openfire users group that I use to push out as contact list to our employess. However, on my new server this isn’t working. Everything looks like it is working on the server side, but the contact list isn’t there on the chat client. To be clear, this is how I tried to push the group:

Users/Groups -> Groups -> Group Summary -> openfire users group -> Once there, I selected “Enable contact list group sharing” and entered a group name -> Save Contact List Settings.

I’ve tried this both with additions user sharing and without, neither pushed the contact list to the group members.

Another interesting note, If I go into the users, select a user then view the roster for that user, it shows everyone that should be in their contact list and says they are a member of the openfire user group. I don’t have this problem on our 3.8.1 server on a windows box.

Thanks…

Okay, in typical fashion the problem seems to have resolved itself now that I finally asked about it. Not sure what changed, but just in case here is what I did. I removed the contact sharing and cleared the rosters for the users. Then I bounced the openfire service and re-added the contact list. That resolved the issue this time, but I restarted the service before so I don’t know what changed.