powered by Jive Software

Contacts Do Not Show Online

We seem to be having a similiar problem as bnpit http://www.igniterealtime.org/forum/thread.jspa?threadID=27016&tstart=0 .

One of our users can log onto the server fine but cannot see anyone online until I add the contacts that show offline to a non shared group, then they will show online until you log off and reconnect, then you have to add them again to see them online again.

We are using Version 2.5.3 on Windows XP Pro SP2. I did try the beta 2.5.4 but with that installed Spark did not seem to be running but it did show on the list of running processes even though there were no other signs of it running. I’'m not sure if that is related to the contact list problem at all or a second issue. I next uninstalled the beta and reinstalled 2.5.3 again which brought me back to square one with no users showing online.

The rest of the users in the group seem to be fine. I’'m hoping someone has a more permanent fix rather than adding the contacts each time you log off or get kicked off because of the server dropping off. Any help/advice would be appreciated. Thank you.

I did find 2 error log files. One had not been changed since last October. The other had the text below repeating over and over.

Exception in thread “AWT-EventQueue-0” java.lang.NullPointerException

at org.jivesoftware.spark.ui.conferences.ConferenceServices.getDefaultServiceName( ConferenceServices.java:306)

at org.jivesoftware.spark.ui.conferences.ConferenceServices.startConference(Confer enceServices.java:387)

at org.jivesoftware.spark.ui.conferences.ConferenceServices.access$100(ConferenceS ervices.java:64)

at org.jivesoftware.spark.ui.conferences.ConferenceServices$7.actionPerformed(Conf erenceServices.java:336)

at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)

at javax.swing.AbstractButton$Handler.actionPerformed(Unknown Source)

at javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)

at javax.swing.DefaultButtonModel.setPressed(Unknown Source)

at javax.swing.AbstractButton.doClick(Unknown Source)

at javax.swing.plaf.basic.BasicMenuItemUI.doClick(Unknown Source)

at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(Unknown Source)

at java.awt.Component.processMouseEvent(Unknown Source)

at javax.swing.JComponent.processMouseEvent(Unknown Source)

at java.awt.Component.processEvent(Unknown Source)

at java.awt.Container.processEvent(Unknown Source)

at java.awt.Component.dispatchEventImpl(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)

at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)

at java.awt.Container.dispatchEventImpl(Unknown Source)

at java.awt.Window.dispatchEventImpl(Unknown Source)

at java.awt.Component.dispatchEvent(Unknown Source)

at java.awt.EventQueue.dispatchEvent(Unknown Source)

at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)

at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.pumpEvents(Unknown Source)

at java.awt.EventDispatchThread.run(Unknown Source)

Message was edited by: MasterTech

Just tried the 2.5.4 non-beta release and got the same problem when the beta installed. Update seems to install ok, but when clicking on Spark to start, you see an hourglass briefly like it is going to start and run, then nothing else happens, no icon on system tray, no contact list box popping up and not showing on the taskbar either, but it does show as a running process using approximately 38,000k of memory. Again, any help would be most appreciated. Thanks.

bump

MasterTech wrote:

Just tried the 2.5.4 non-beta release and got the same problem when the beta installed. Update seems to install ok, but when clicking on Spark to start, you see an hourglass briefly like it is going to start and run, then nothing else happens, no icon on system tray, no contact list box popping up and not showing on the taskbar either, but it does show as a running process using approximately 38,000k of memory. Again, any help would be most appreciated. Thanks.

in my case i sometimes have to run Spark with admin rights after the upgrade if i want to use it with limited user, because Spark needs to unpack something in program files.