powered by Jive Software

Could not route packet

Hi there,

getting these messages when trying to connect/register to Jive Messanger 1.1


2004.10.14 12:02 [com.jivesoftware.xmpp.spi.IQRouterImpl.handle(IQRouterImpl.java:153)

] Could not route packet

java.lang.NullPointerException

at com.jivesoftware.xmpp.spi.IQRouterImpl.handle(IQRouterImpl.java:95)

at com.jivesoftware.xmpp.spi.IQRouterImpl.route(IQRouterImpl.java:61)

at com.jivesoftware.xmpp.spi.PacketRouterImpl.route(PacketRouterImpl.java:73)

at com.jivesoftware.xmpp.net.SocketReadThread.readStream(SocketReadThread.java:213 )

at com.jivesoftware.xmpp.net.SocketReadThread.run(SocketReadThread.java:97)


Tried both the zerog package, and standalone zip.

Any ideas?

//b0bben

Thanks for the bug report. Besides the stack trace that you found in the log file, are you having any problem connecting or registering with the server?

BTW, what client are you using? It could help if you could post the XML packets that the client sent to the server.

Thanks,

– Gato

Hi again,

I was using Neosm client. I think i tried with exodus too, not sure though…

I can’‘t provide any more debug info today, i’'m on a deadline which is due today, and i need to code some more

I could try it out over the weekend, or on monday again.

Where exactly is the debug log for client-server xml conversation?

Tried with setting the server in debug mode in webadmin, but it didn’'t produce any logs…

cheers

bob

Bob,

I never used Neosm but in Exodus you can press F12 to get the debugger window.

Regards,

– Gato