powered by Jive Software

Crowd Integration for Openfire 3.9.3

Server: Centos 7

Openfire Version: 3.9.3

I have openfire up and running and was trying to get Crowd integration with openfire running. I found the post on antelink.com (This) which is a few years old and backed out those changes when I got the to crowd.properties and found the file under the config directory in my install.

As noted I backed out the changes ensured that everything worked when returning to default after restarting openfire.

So a few questions.

-Is there a current crowd guide for version 3.9.X?

-The settings listed in the default crowd.properties file are those settings which should be added to the System properties or just in the crowd.properties file?

-If the System properties under (Server > Server Manager > System Properties) should not be updated how can I restore defaults?

-Running crowd.properties

-I have imported my crowd ssl cert into the server but java is still complaining any thoughts?

-Openfire Error log

Note: In an effort to keep this post clean I have used pastebin.com if I should put my full configs and such in posts just let me know.

Thanks,

In the hope of helping someone else who finds this post here is how I got XMPP clients authenticating but still unable to get it working for the administrator portal.

To get this working there are three parts.

A. Update the following properties at (Server > Server Manager > System Properties).

admin.authorizedGroups =

provider.admin.className = org.jivesoftware.openfire.crowd.CrowdAdminProvider

provider.auth.className = org.jivesoftware.openfire.crowd.CrowdAuthProvider

provider.group.className = org.jivesoftware.openfire.crowd.CrowdGroupProvider

provider.user.className = org.jivesoftware.openfire.crowd.CrowdUserProvider

crowd.groups.cache.ttl.seconds = 3600

crowd.users.cache.ttl.seconds = 3600

#These fields are needed if Crowd server uses SSL Certificate

clearspace.certificate.verify = false

clearspace.certificate.verify.root = false

B. Update your crowd.properties manually in your openfire/conf directory. Add the following.

application.name=

application.password=

application.login.url=

crowd.server.url=

session.isauthenticated=session.isauthenticated

session.tokenkey=session.tokenkey

session.validationinterval=0

session.lastvalidation=session.lastvalidation

#http.proxy.host=

#http.proxy.port=

#http.proxy.username=

#http.proxy.password=

http.max.connections=20

http.socket.timeout=20000

http.timeout=5000

#These fields are needed if Crowd server uses SSL Certificate

C. Add SSL Certificate if your Crowd Server uses SSL.

I found that adding the certificate to the standard keystore does not work as openfire will only check its own key stores.

openfire/resources/security/

From here I restarted the server and while the Administration console did not work logging into the XMPP server works for all my users.

Adding the “admin.authorizedGroups” to the system properties the admin console now works for appropriate users. Also moved the “Clearspace.certificate.verify” options to the system properties.