powered by Jive Software

Custom away status will keep showing up when idle (even after deleted)

I figured there had to be a an open issue on this problem by now, but I cannot find one.

I am running the latest production version of Spark, 2.6.3. I have had this issue where if I set a custom away status, it becomes my permanent Idle away status.

Example:

  1. Set my Away status to something temporary, “Running to the bathroom, be back in 5!” (do NOT check “Save for future use”).

  2. Come back to my desk, set myself back to Online.

  3. Eventually leave for the day, or go away for several hours. Expect it to set me to Idle Away, or simply “Away”.

  4. Come back to my desk hours later, or the morning after, and my Away status has reverted to my custom message, “Running to the bathroom, be back in 5!”

Please tell me I am not alone on this? :slight_smile: I had this issue for a year or so. I tried uninstalling, reinstalling. Also removing all my AppData for Spark. A few months ago I had to completely reload my workstation. I thought I clean install would do me good. But it came right back!

Can’t reproduce this with the latest 2.7.0 nightly builds. So it probably has been fixed some time ago. You can try 2.7.0 http://bamboo.igniterealtime.org/artifact/SPARK-INSTALL4J/shared/build-665/Insta ll4j/spark_2_7_0_665.exe

I was trying to avoid using the nightly code. It seems to have a realm of bugs all it’s own! But I will give it a shot for a week or so to see if it resolves this odd issue.

I will report back in a week or so!

I’m using latest builds all the time. And all my users Well, they are now on 630 or something. There were nothing significant in the latest changes worth upgrading all. Yeah, it can hang for a moment sometimes, like 2.6.3 did, but it’s pretty stable.

Well I have been running the nightly since June 17th (so not the latest nightly obviously) but I still seem to have this issue. A while back I set a custom Online status to indicate that I was online - but still offsite working. And now, every morning, it’s set back to that status. It haunts me!

Can’t reproduce this either. Do you still have this “online - but still offsite working” status saved in the list? Maybe it is bugged from the older versions. Try deleting it and create a new if you need it.

I don’t have this particular status saved, but I do have an away message saved in there, and it does not seem to be coming back. That’s what made me think that I had escaped this issue!

If you cannot reproduce it, there has to be something different about my environment. I am running Spark on Windows 7 Professional, SP1 and Java 1.7.0_55. What do you have?

I have various setups for testing. Was testing this on:

Windows XP SP3, Spark 2.7.0 659, using its internal Java 1.7.0_51

Windows 7 SP1 x64, Spark 2.7.0 665, using system’s Java 1.8.0_05

I don’t think setup matters here. To me it’s more like a corruption in a profile. Check C:\Users\user\AppData\Roaming\Spark\user\user@server\custom_messages.xml

Does it have the haunting message inside? Try exit the Spark and delete this file. Create new status messages. If that doesn’t help. Then you can start with a fresh Spark profile. Save C:\Users\user\AppData\Roaming\Spark\user\user@server\transcripts folder and maybe C:\Users\user\AppData\Roaming\Spark\spark.properties file. Then delete C:\Users\user\AppData\Roaming\Spark. Start Spark and let it create a new profile. You can first check if everything works ok without copying back settings and transcripts.

Sorry to bring this issue back from the grave - but I still have the problem, and I have a new clue to offer. My co-workers have had problems when connecting to PC (running Spark) when using remote desktop. In their case, they are seeing everyone disappear from their group list, and I suspect that this is more of an AD problem which has it’s own open bug assigned to it. But I am not ruling out the remote desktop as being part of the problem.

It occurred to me that I use remote desktop throughout the day to connect back to my desk, and after hours from home using a VPN.

Can someone try to reproduce this using a PC running Spark and remote desktop to get into it?