powered by Jive Software

Custom table for openfire users instead of ofusers

Hello,

I’ve the following xml as the config xml /openfire.xml. I’m planning to use our users table for the users instead of using the openfire usr table. But after following the instructions in the documentation as well as searching in the internet I’ve implemented , but it is not working as expected. I’m not able to login into the admin console after doing this, with a different user.

Thanks

<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?> <!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>     Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive>   <admin><authorizedUsernames>joe, jane</authorizedUsernames></admin>
<adminConsole>     <!-- Disable either port by setting the value to -1 -->      <port>9090</port>      <securePort>9091</securePort>   </adminConsole>    <locale>en</locale>    <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->    <!--
    <network>
        <interface></interface>
    </network>
    -->    <connectionProvider>     <className>org.jivesoftware.database.DefaultConnectionProvider</className>   </connectionProvider>    <database>     <defaultProvider>       <driver>com.mysql.jdbc.Driver</driver>        <serverURL>jdbc:mysql://localhost:3306/test</serverURL>        <username>root</username>        <password>test</password>        <testSQL>select 1</testSQL>        <testBeforeUse>true</testBeforeUse>        <testAfterUse>true</testAfterUse>        <minConnections>5</minConnections>        <maxConnections>25</maxConnections>        <connectionTimeout>1.0</connectionTimeout>     </defaultProvider>   </database>    <setup>true</setup>    <jdbcProvider>     <driver>com.mysql.jdbc.Driver</driver>      <connectionString>jdbc:mysql://localhost:3306/test?user=root&amp;password=teset</connectionString>   </jdbcProvider>    <provider>     <auth>       <className>org.jivesoftware.openfire.auth.JDBCAuthProvider</className>     </auth>      <user>       <className>org.jivesoftware.openfire.user.JDBCUserProvider</className>     </user>   </provider>    <jdbcAuthProvider>     <passwordSQL>SELECT password FROM users WHERE userLoginName=?</passwordSQL>      <passwordType>plain</passwordType>   </jdbcAuthProvider>    <jdbcUserProvider>     <loadUserSQL>SELECT CONCAT(pe.firstname,' ',pe.lastname),pe.email FROM users AS us,person AS pe WHERE us.userLoginName=? AND pe.personId = us.personId</loadUserSQL>      <userCountSQL>SELECT COUNT(*) FROM users</userCountSQL>      <allUsersSQL>SELECT userLoginName FROM users</allUsersSQL>      <searchSQL>SELECT us.userLoginName FROM users as us,person as pe WHERE</searchSQL>      <usernameField>us.userLoginName</usernameField>      <nameField>CONCAT(pe.firstname,' ',pe.lastname)</nameField>      <emailField>pe.email</emailField>   </jdbcUserProvider>    <log>     <debug>       <enabled>true</enabled>     </debug>   </log> </jive>
ile stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
    <network>

Message was edited by: sai

Any help?

Hi,

I hope that you xml file is well-formed, your post contains 2x “<xml” and some lines after “”. Did you adust the “” section or are you using joe as admin?

LG

Please look at the following xml. this is actual. Thanks for the reply. Thanks for the reply. Please let me know what all settings i’ve to do to gt it done. I’ve even lookd at the source code. Which source file should i look for finding out that the openfire is working properly by using our applications table

<?xml version="1.0" encoding="UTF-8"?>
<?xml version="1.0" encoding="UTF-8"?> <!--
    This file stores bootstrap properties needed by Openfire.
    Property names must be in the format: "prop.name.is.blah=value"
    That will be stored as:
        <prop>
            <name>
                <is>
                    <blah>value</blah>
                </is>
            </name>
        </prop>     Most properties are stored in the Openfire database. A
    property viewer and editor is included in the admin console.
-->
<!-- root element, all properties must be under this element -->
<jive>   <admin/>    <adminConsole>     <!-- Disable either port by setting the value to -1 -->      <port>9090</port>      <securePort>9091</securePort>   </adminConsole>    <locale>en</locale>    <!-- Network settings. By default, Openfire will bind to all network interfaces.
      Alternatively, you can specify a specific network interfaces that the server
      will listen on. For example, 127.0.0.1. This setting is generally only useful
       on multi-homed servers. -->    <!--
    <network>
        <interface></interface>
    </network>
    -->    <connectionProvider>     <className>org.jivesoftware.database.EmbeddedConnectionProvider</className>   </connectionProvider>    <setup>true</setup>    <jdbcProvider>     <driver>com.mysql.jdbc.Driver</driver>      <connectionString>jdbc:mysql://localhost:3306/gcsprimedev?user=root&amp;password=pass</connectionString>   </jdbcProvider>    <provider>     <auth>       <className>org.jivesoftware.openfire.auth.JDBCAuthProvider</className>     </auth>      <user>       <className>org.jivesoftware.openfire.user.JDBCUserProvider</className>     </user>   </provider>    <jdbcAuthProvider>     <passwordSQL>SELECT password FROM users WHERE userLoginName=?</passwordSQL>      <passwordType>plain</passwordType>   </jdbcAuthProvider>    <jdbcUserProvider>     <loadUserSQL>SELECT CONCAT(pe.firstname,' ',pe.lastname),pe.email FROM users AS us,person AS pe WHERE us.userLoginName=? AND pe.personId = us.personId</loadUserSQL>      <userCountSQL>SELECT COUNT(*) FROM users</userCountSQL>      <allUsersSQL>SELECT userLoginName FROM users</allUsersSQL>      <searchSQL>SELECT us.userLoginName FROM users as us,person as pe WHERE</searchSQL>      <usernameField>us.userLoginName</usernameField>      <nameField>CONCAT(pe.firstname,' ',pe.lastname)</nameField>      <emailField>pe.email</emailField>   </jdbcUserProvider>    <log>     <debug>       <enabled>true</enabled>     </debug>   </log> </jive>

Message was edited by: sai

Ignore the <?xml oln the top. plz. there is some problem with the forum xml format text.

Yes, I’m using the joe as the admin. You are not seeing the admin in the above xml, coz when i ran the server after setting the in the xml, the server is removing the secion of the openfire.xml.

Help plz…

I’ve checked out the source. When i run the souce with the xml i’ve posted before, it works fine. Thats a good news. But the build which is in the downloads does nt work the way it has to.