powered by Jive Software

Death to emoticons

I really want to roll out Spark 2.5.1 to my users. However, I am in an industry where the emoticons are not acceptable. I understand that I can disable emoticons in the Spark setup but can another user just come after and enable them.

I would like a way where they can be disabled and not even be seen in the message window. I have played and deleted the xtra folder they come in, but when I enable them they appear back and are usable.

I am still running SPARK 1.0.2 because it does not have emoticons. Unfortunately the DST issues have a wrong time now showing. Unless there is a fix for that???

Any ideas would be greatly appreciated.

Thanks for the input. I’'ve gone ahead and added this as a Feature Request inside Enterprise. If approved, a JIRA issue will be filed for better tracking.

Cheers,

Derek

ddman wrote:

Thanks for the input. I’'ve gone ahead and added this as a Feature Request inside Enterprise. If approved, a JIRA issue will be filed for better tracking.

What? I must missunderstand something. Are you going to add Emoticon disabling in chat window and history Enterprise only?

Couldn’'t you just remove the directory that contains the emoticon graphic zip files?

The issue is that even though there is an option to disable emoticons already, each user would need to go to preferences to do that. The issue is that we do not offer a build that just does not come with emoticons. That is why I thought Enterprise would be the right place for something like that. How else do you roll out custom builds and executables?

Cheers,

Derek

Ah, we are talking about different things I was speaking about user side disabling of emoticons. There are JIRA issue which is marked solved, but it only disables Emoticon toolbar icon, user still can type regexpressions which will be shown as icons, and all history is shown with icons. I think disabling of emoticons should disable regexpressions substitution with icons too.

SPARK-296

I have tried deleting all the zip files in the ‘‘xtra’’ folder. When you restart Spark you can still enable and see and send the emoticons.

I have even deleted the ‘‘xtra’’ folder. Same thing happens. It appears that the emoticons must be loaded somewhere else as well?

So if it’'s not a fresh install, you will want to remove the xtra folder from your user.home/Spark directory as well. ex (c:
document and settings
username
Spark)

Cheers,

Derek

We have had the same issue, where the emoticons are not desirable.

we did delete the xtra folder, however the spark client seem to become unstable after that. Especially when entering conference rooms. some of the strange behaviour was 1) we could not chat in a conference room, everytime we did just the user name would show up in the chat box 2) the behaviour was really noticeable when in multiple conference rooms. For the time being we are leaving the emoticons in until we figure out what is causing the strange behaviour.

I guess anthoer way would be to create a empty emoticon set. I think the Emoticon.plist file would be:

Message was edited by: rminsk

ddman wrote:

So if it’'s not a fresh install, you will want to remove the xtra folder from your user.home/Spark directory as well. ex (c:
document and settings
username
Spark)

Cheers,

Derek

I have done fresh install as well as tried the above process. After the above process I get the same issues Trevinator received

rminsk wrote:

I guess anthoer way would be to create a empty emoticon set. I think the Emoticon.plist file would be:

<?xml version="1.0" encoding="UTF-8"?>

SparkSetVersion

1

Emoticons

Message was edited by: rminsk

I don’'t know if I have fixed this issue somewhat but here is what I have done.

Used rminsk’'s plist file and replaced that in every folder…so this means all the lists in the icon folders in the (c:
program files
Spark
xtra
emoticon) as well as (c:
document and settings
username
Spark)

I also deleted all of the .png files from these folders as well.

I have tested this morning and so far my conferencing and private messaging appears to be working fine. No signs of emoticons anywhere.

I also have the “enable emoticons” option turned on. I have lost the spell check icon above the text entry field. I will continue to test today.

I did not mean for you to replace the plist file in all the different emoticon directories. My thought was to get rid of all the emoticon directorys and create a new “empty” emoticon set. It seems you may have things working somewhat.