powered by Jive Software

Decreasing Java Memory usage

Hello,

Recently, I’ve noticed on the admin console that the java memory has been at 100% usage (989mb out of 989mb). It caused several crashes to our Spark.

I’ve increased the memory to 1.5GB today , it now sits at 1.3GB usage… but we still experienced a crash due to heap.

Is there anything that I can clear or clean to decrease the CPU usage? It was never this high before until 2 weeks ago.

Are you using Java 8 and Openfire 4.2.1 ?

Our Openfire installation uses 2-5 GB memory. Currently as I watch the UI, it says:
5194.94 MB

So I guess this is normal.
Java 8, Openfire 4.0.3

Depends on the usage. We had only 1,2 GB allocated to JVM and it never used max with 200 users. It woud be hard to find out what causes increase in memory usage (new user, new roster, avatars, more MUC messages, etc.). Probably easier to just give it more memory via properties file. And maybe move to 64 bit version to be able to give more memory than ~1,2 or so.

Hi, we’re using version 4.1.6 with Java 8.

We have about 50 - 60 users only. Running on a 32bit platform, will have to look into upgrading to 64bit perhaps. If I install a 64bit version, will be 32bit backup folders still work?

This morning it is sitting at 82.2% usage. 1232mb/1498mb. Should I try increasing it to 2GB ram? Would you know the configuration? 1550 = 1.5GB.

Hi guys, just an update. I realize the usage climbs alot when I join any conference rooms. Would it be possible that the history in those conference rooms is causing the load? Is there any way to clear it?

There was a bug in recent versions with MUC if i recall correctly. So, updating to 4.2.1 would be useful probably. You can try disabling history for a particular room and then enable it again. Not sure if it will wipe all history from the database. You can also try destroying and recreating rooms to be sure that history is wiped.

Not sure what you meant about backup folders. You also haven’t mentioned what OS you are using. On Windows you can install 64-bit version on top of 32-bit. So when running the installer, you should manually point to C:\Program files (x86)\Openfire (if installed there) and it will uninstall 32-bit and install 64-bit version in that folder. You can then increase it more that just 2 GB, depends on memory amount on the server. You can just set it to 2000 or 3000, i don’t think it have to be in x2 increments (32, 64, 128, etc.).

We’re running it on Windows Server 2012 R2 64bit. I guess the initiating team installed a 32bit instead of 64. I re-created all the rooms to test, so far so good… will keep everyone updated.

Sorry, when I was referring to the backup folders I meant to ask if I will have to re-configure all the settings again because as you mentioned above, the 64 version will write on top of the existing.

64-bit installers were made available only recently, so your team probably had no choice back then.

Openfire keeps configuration when upgrading. Same goes when switching from 32 to 64 bit (or vice versa). Of course, doing a backup before upgrading is always a good practice.