powered by Jive Software

Departmental OUs in Contact list

Hello all,

We’re currently testing Openfire and Spark to create efficiencies within our company to allow engineers to contact the people they need, instantly at their computers, without having to move to an office and call them. As well as creating other efficiencies for the departments (IE Support roles, and Purchasing)

I’m trying to configure Openfire to work with Spark and “preload” contacts into the contact list.

My Base DN is = OU=“Departments”,DC=“KLMUKE”,DC=“NET”

Our AD structure looks like the following

KLMUKE.net

           Departments - OU

                        Finance- Departmental OU

                                Payroll - JobTitle OU

                                       (User)

                                Finance Manager

                                       (User)

                                Accountant

                                          (User)

                        IT

                            ITSupportTechnician

                                            (User)

                            NetworkAdministrator

                                           (User)

                            IT manager

                                            (User)

                        HR

                            HRAdmin

                                       (User)

                            HROfficer

                                       (User)

Whenever I attempt to add the departmental OU to the contacts list. They’re not added. I ran a test by creating a test user in the root of the departmental OU and the user showed up in the contacts.

Is their a way I can add all the departmental OUs to the contact list without having to add the Jobtitle USG’s as we have over 100 Jobtitles and I don’t want to make the contacts list messy and disorganised.

Is their a way I can do this? Anyhelp is greatly appreciated

you can add Groups in your Openfire user config… and each Group could be a department…

I.E Create my own group, and then add the job title USGs to that?

Because when I try, I just get

“Not allowed: the group account system is read-only.”

And after some looking

"Directory Server (LDAP) - Integrate with a directory server such as Active Directory or OpenLDAP using the LDAP protocol. Users and groups are stored in the directory and treated as read-only."

I’m not going to create 400 users to get this to work. Was hoping it would work on the fly from AD

well, i’ve not used the AD integration, but it should work given you set it up properly. there’s many many threads on this forum of other users getting AD integration to work properly… perhaps one of them solved the same problem?

Where is this error coming from? Openfire or on your DC? The error seems to indicate something is trying to modify or write something, however as you noted Openfire only will read AD info… it will not write it back.

This is what I do to basicly accomplish what you are trying to do.

Hi,

Sadly this is not a feasable solution to the issue.

I think we’re going to have to look into paid for solutions

Admitidly Openfire and spark seem like a great app, and would recommend it, but sadly it doesn’t do what the company wants it to.

Thanks for all your help

that’s a shame , it seems speedy’s guide would do what you are looking for… 1 group per OU, which will show up in your Spark client roster page under separate headings (groups).

(Also, just be aware, there are many paid XMPP servers out there, of which, several are Openfire in disguise, such as the Cisco Finesse product, and Cisco’s WebEx product, which both bundle Openfire with several other products into a single package)

Well we do have some groups, we call them Hash groups, as all groups are prefixed with a # and thse contain the users

These are purely Email distrobution groups and have been superceeded by the security groups and will be removed in the next month or so as the # groups where an old solution when we were on an old NT domain.

I can put the idea forward to our network administrator, but I don’t think he’ll like the idea of having old hat on a new head… so to speak.