powered by Jive Software

Deploying war under JBoss

Does anyone have any experience deploying the wildfire war under jboss? All I get is :

java.io.FileNotFoundException: XML properties file does not exist: wildfire.xml

This happens no matter where I put the wildfire.xml/wildfire_init.xml file. I have put it inside the war, creating the classes directory in the WEB_INF folder. I also put it directly in WEB_INF and in the base. I have put the xml file in the conf directories, both for jboss (server/default/conf) and Tomcat conf (server\default\deploy\jbossweb-tomcat55.sar\conf), the last out of desperation.

I have defined wildireHome as a system wide environment variable and defined it on the command line in run.bat for jboss.

Any tips anyone?

Also a couple of questions :

Should this

C:
jive-repo
wildfire
target
war
wildfireHome

in fact be :

C:/jive-repo/wildfire/target/war/wildfireHome

This is all based on the installation document found at http://www.jivesoftware.org/community/entry.jspa?externalID=431&categoryID=22

Any help would be greatly appreciated as this looks great and i can’'t seem to get it up and running due to, what seems to be, simply one xml configuration file!

Thanks in advance to anyone who helps.

Forgot to mention I am running JBoss 4.0.2

Hola Paulo,

I never tried Wildfire under JBoss. Having said that I will try to help you out (if I can).

The wildfire.xml file should live in /conf. So if your wildfireHome variable points to c:\installs\wildfire. You should then have the following structure:

C:\installs\wildfire\wildfireHome

C:\installs\wildfire\wildfireHome\conf

C:\installs\wildfire\wildfireHome\plugins

C:\installs\wildfire\wildfireHome\resources

C:\installs\wildfire\wildfireHome\resources\database

C:\installs\wildfire\wildfireHome\resources\nativeAuth

C:\installs\wildfire\wildfireHome\resources\security

Attached to this post you will find the structure and the files contained in each folder. I think that we are going to need to improve the download page to include a the wildfireHome folder content. Sorry about that.

Saludos,

– Gato

I tried to set the wildfireHome variable but it doesnt work for me. I also tried to point the parent dir but the error message still said that the wilfire.xml was not found.

Maybe Jboss is somehow hiding environment variables ???

Anyways, the other method works ( using the wildfire_init.xml file ) … with a content like that :

Hola Gato

That has solved the problem!

So the missing file was in fact the wildfire.xml in the conf directory.

So, to sumarize how I solved it :

Unzip the attached zip into my wildfireHome, and then added a wildfire_init.xml file to the war directly, creating a classes[/i] directory in the WEB-INF[/i] directory. My wildfire_init.xml[/i] contains :

[/i]

Thanks again.

Some sugestions :

  • The jiveHome xml tag should be wildfireHome (I suppose this one’'s obvious! just pointing it out )

  • Provide a way of keeping the wildfireHome directory inside the war or in the database or some other method. This is just something I don’'t like : a sort of tmp directory somewhere on disk.

  • Database schema setup automatically on first depoly and/or if database indicated is found to not contain necessary schema.

Anyways, just some constructive sugestions that I hope are helpful.

Thanks for the help and keep up the good work!

Also the documentation should be updated. Maybe I can help?

For JBoss 4.0.4CR2, I got it working by setting the environment variable using the JAVA_OPTS settings in “$/bin/run.conf”. I couldn’'t, for the life of me find where to put the “wildfire_init.xml” file to make it work, though. I tried the “$/server/default/conf/” directory and tried inserting it into the WAR file in the “WEB-INF/classes/” directory, with neither working.

Anyway, I hope this helps somebody looking for the option of using the environment variable.