powered by Jive Software

Disable non-SSL connections (5222)

Is there a way to disable non-SSL connections so that my users must enable SSL in order to connect to the server?

Nathan

Change the client port from Admin Console? Security by obscurity? heh…

Server

Server Settings

Edit Server Properties

Client Port: 5222 <— change to ?

Restart server.

In System Properties

Add this property:

Property Name: xmpp.socket.plain.active

Property value: false

Restart the server - it won’'t be listening on 5222 anymore.

Thank you, that did it.

Nathan