powered by Jive Software

Disable OTR plugins

With Openfire 3.7.1 how do you stop users from using say Pidgin OTR

I see how you do it in Spark …

Thanks

Jeff

If your able to drop messages on the server side you could filter the otr init message.

A secure connection will be initiated with an otr key word in plaintext. Depending on the version of otr the client uses it sends “?OTRv2?” for version 2. When you drop those messages the clients wont be able to connect each other.

ugg its running

3.6.4

Been tring to get the ruddy thing to upgrade with no luck odd

I have disabled OTR for all clients with OpenFire’s content filtering.

Go to Server -> Server Settings -> Content Filter. Set your pattern to “?OTR” and enable the filter.

Users attempting to enable OTR chat will see it trying to initialize and it will timeout after 10 seconds. My few users that used it think that an upgrade I performed “inadvertently broke it”.

My issue was it was not Updateing , said it did, but on our Slave I did a md5 on the dir /opt/openfire, seems my other was bigger , so

tar’d it up and moved to other server

BANG all is well.

No idea why the RPM ran , same one i did on both … odd very odd

Thanks

Jeff

Need to install “Content Filter” plugin available in Openfire plugins list and added the info in the filter then need to do

Go to Server -> Server Settings -> Content Filter. Set your pattern to “?OTR” and enable the filter.

Thanks.