powered by Jive Software

Disabling OTR in Spark2.6.3

Hi All,

Please help me how I can disable OTR in Spark 2.6.3?

Can any one please tell me location of source code?

Thanks

JPS

Hi

please read the document in Spark Dev: http://community.igniterealtime.org/docs/DOC-2163

and maybe you wan to search a bit in the forum. It has been a topic several times before. OTR can be blacklisted in Spark an no installation or usage is possible.

Walter

Thanks a lot!

I am already trying to change properties and make a Spark.exe for distribution

Is there any way to do this from server side configuration? something like disabling SSL/TSL in openfire??? will it have any impat? or any other solution at server side???

No, there is no option to turn off plugins from the server.

You can Packet-Filter the OTR-Handshaking process, but thats not documented and youll need to find out yourself how to do that

what kind of “disabling” do you mean? you could switch it off in the preferences or uninstall it using the plugin manager.

if you want to deploy spark without otr you have to remove the otrplug.jar from plugins folder or remove the build instruction in spark ant build file.

there is atm no plugin that filters otr messages or handshakes, as wolf mentioned.

If there would be one, i guess there will be soon an otr plugin update to bypass this filter

Packet-filtering, or content-filtering, rather, is how I’ve disabled OTR for my users. It’s pretty simple:

Go to Server -> Server Settings -> Content Filter. Set your pattern to “?OTR” and enable the filter.

Users attempting to enable OTR chat will see it trying to initialize and it will timeout after 10 seconds. My few users that used it think that an upgrade I performed “inadvertently broke it”.

2 Likes

Deevil wrote:

Packet-filtering, or content-filtering, rather, is how I’ve disabled OTR for my users. It’s pretty simple:

Go to Server -> Server Settings -> Content Filter. Set your pattern to “?OTR” and enable the filter.

Users attempting to enable OTR chat will see it trying to initialize and it will timeout after 10 seconds. My few users that used it think that an upgrade I performed “inadvertently broke it”.

Worked like a champ. I am catchin some peculiar glances right now. Thanks for the tip!

V