DNS lookup failure for conference service

I’ve just installed the openfire server for my group here at work and we’d like to take advantage of the group chat features of the server. I have it setup to authenticate against AD and have all users and groups listed.

I created a room which would be roomname@conference.chat.mgnt.domain.com.

In my client (Adium on OSX) I go through the join group chat process but receive a 404 error.

When looking at the logs I see messages like the following:

2008.12.05 11:45:34 [org.jivesoftware.openfire.session.LocalOutgoingServerSession.createOutgoingSes sion(LocalOutgoingServerSession.java:258)] Error trying
to connect to remote server: endeca.com(DNS lookup: domain.com:5269)
java.net.ConnectException: Connection refused

From the server running the openfire server I am able to successfully perform DNS lookups of conference.chat.mgnt.domain.com.

Any ideas what’s going on?


this server does not seem to be related to the conference service.

“Error trying to connect to remote server: example.com(DNS lookup: domain.com:5269) java.net.ConnectException: Connection refused” means that someone wants to connect to another server.

I wonder whether you are using the xmpp.domain which you did configure within Openfire or the computer name.


I see these error messages when I try to join a group chat (from my client Adium on OSX) that I’ve configured in the admin UI. Does xmpp.domain get set in the openfire.xml file? There seems to be a lot of configuration parameters I configured during setup which are not present in that file. Where else might I find it? Also what would I need to set it to?

I’m new to openfire and may be misreading this error message, but it sure reads like the openfire server cannot lookup the name in place (conference.chat.mgnt.domain.com).

I will go hunt around for the xmpp.domain setting and appreciate any other insight to be had on this issue.

most of the settings are now located in the system properties for easier editing. You access these via the openfire admin website.

The server name, xmpp.domain, and the server certificates should all have or be based on the same fully qualified domain name, in your case chat.mgnt.domain.com.


on http://foobar:9090/index.jsp you can see the server name (xmpp.domain) and the host name which has nothing to do with chat.

On /server-properties.jsp there’s also the xmpp.domain property listed again.

To change the xmpp.domain you need to modify it everywhere in the database and restart then Openfire. So installing Openfire again is usually more easy.

The (sub domain) name of your conference room should be configured on /muc-service-summary.jsp and it is ususally “conference”.

So your clients should try to enter “conference.$(xmpp.domain)” and not conference.hostname.


As a general rule to ensure all features of openfire will work if and when you choose to use them you should use a fully qualified domain name for the server name and xmpp.domain. This will in turn make the certificates match if you generate them via the admin console. Some argue this is not needed but I have found that such features as SSO and Fastpath will not work correctly unless openfire is configured this way.

Looks like my problem was self inflicted. chat.mgnt.domain.com was a CNAME to the FQDN of the server hosting the openfire server and so conference.chat.mgnt.domain.com was not working because the xmpp.domain setting was the FQDN of the server. Once clients were reconfigured to use the FQDN of the server, the group chat worked.

Thanks for all the replies.