powered by Jive Software

DNS Srv records Active Directory

I might be stuck on stupid, but when I try to login to my jive server from Exodus, with xml debug turned on, the login fails because it can’'t find a SRV record in the dns server.

When I attempt to add the record, (w2k SBS) the management console doesn’'t offer support for any xmpp protocols.

Where/how do I add this support, or how do I connect without it??

Thanks!

barcode,

if you are using a Windows 2000 DNS Services as your DNS Server then you can add a SRV record by:

1.) right click on your domain and select ‘‘Other new records’’

2.) In the resource record type choose ‘‘Service Location’’ and select ‘‘create record’’

3.) for service enter ‘’_xmpp’’ for protocol choose ‘’_tcp’’ for port enter ‘‘5269’’ and for host enter your Jive Servers FQDN.

you will have to create a service entry for ‘’_xmpp’’ port 5269 ‘’_xmpp-client’’ port 5222 and ‘’_xmpp-server’’ port 5629 (as described in Step 3)

hope this helps.

Thanks! but… after entering the records, connecting with Exodus shows:

=============

Looking up SRV: xmpp-client.tcp.dixiesbs

Direct DNS failed… Using server: dixiesbs

RECV:

=============

And still no connection. The user has been created within the admin tool.

barcode,

is dixiesbs your full domain? or does your domain follow a conventional name like dixiesbs.com (.net, .org, etc)

after you update your domain DNS Settings with the XMPP protocol, you may also want to flush out the dns in the client machine to have it pull the new dns information for the domain.

also, how are you specifying the username in exodus? username@dixiesbs?

Thanks,

barcode,

also make sure to test out the _xmpp SRV record entry to make sure the DNS Server is servicing the protocol properly.

you can use NSLOOKUP.exe in Windows Command Prompt to assist with the test