powered by Jive Software

DNS SRV support?


I’'m trying to have the spark1.1.1 clients automatically detect wildfire 2.5.0 host and port information.

I have the following DNS SRV records in bind 9.2.4:

xmpp-server.tcp.sheridanc.on.ca. 86400 IN SRV 5 0 5269 im.sheridanc.on.ca.

xmpp-client.tcp.sheridanc.on.ca. 86400 IN SRV 5 0 5222 im.sheridanc.on.ca.

jabber.tcp.sheridanc.on.ca. 86400 IN SRV 5 0 5269 im.sheridanc.on.ca.

And it looks like it resolves correctly:

sentinel:~> dig xmpp-server.tcp.sheridanc.on.ca any +short

5 0 5269 im.sheridanc.on.ca.

sentinel:~> dig xmpp-client.tcp.sheridanc.on.ca any +short

5 0 5222 im.sheridanc.on.ca.

sentinel:~> dig jabber.tcp.sheridanc.on.ca any +short

5 0 5269 im.sheridanc.on.ca.

In the spark client, ''Automatically discover host and port is checked under Advanced->General. My problem is that the ‘‘Login’’ box is greyed out until I put something in the ‘‘Server’’ textfield.

Any ideas?




This isn’‘t actually what DNS SRV is for. What it will do is allow someone to specify “sheridan.on.ca” as the server in the login screen but to have that then use the server “im.sheridan.on.ca”. There’'s not an easy way to make the server auto-discoverable at the moment.



Ah ok, it works as you suggested. However, this takes away from SRV’'s usefulness.

For convenience, our jabber id is the same as the users email ‘‘first.last@sheridanc.on.ca’’. In an Exodus client for example, a user just inputs their email and the client will automatically detect host&port information (since the domain is tacked on the end).

In spark, a user will have to put ‘‘first.last’’ as the username and ‘‘sheridanc.on.ca’’ on the server field. This will lead to confusion. It makes more sense here to just get away from SRV and use the real username and hostname on the login window…unfortunately.

This should be a feature request to collapse the username and server field into one ‘‘jabber id’’ field in the format ‘‘username@domain’’. This is what most of the IM clients do.

Where do we submit feature requests?

Hi Ryan,

this is the right forum to submit feature requests, a developer will read it and probably create an issue for it. If one enters “first.last@server” then Spark could be intelligent and fill the server field with everything below the last[/u] ‘’@’’. http://www.jabber.org/jeps/jep-0106.html specifies that the “node identifier portion of a Jabber Identifier” may contain “disallowed characters” like ‘’@’’. So what if my name contains an ‘’@’’ character?

I have no idea how you plan to install Spark for all users, in my opinion you want to customize the settings.xml file and copy it over the original one after installation, so you can add username, initial password and server there. If you do it like this then you do no t need such a feature.


It’‘s not an issue for us, our mail addresses do not contain invalid characters outlined in the jep you provided (or they’'ll have problems sending mail as well!).

The xml files do help but I still think that it’'s cleaner to collapse the 2 fields.