powered by Jive Software

Do you support AMD 64 bit?

Running Spark 2.0.5 (2.0.4 fails, too). I’‘m using Linux CentOS 4.3, 2.6.9-42.0.2.ELsmp kernel on an AMD Athlon 64 X2 Dual Core Processor 4800+ CPU system. I am running KDE (if that matters) and jre1.5.0_09. I’'ve installed the newest, stable jvm from Sun, it let it install fine and it runs okay at first.

It allows a login to our jabber server running wildfire and rejects the login if it’‘s not correct. The problem is that I only see a blank window. There’‘s no user lists, no options, etc. The “Contacts” and “Options” buttons do nothing. Is this unsupported? This works for other staff local and remote using Windows or Linux with 32 bit support. I’'m the only one running 64 bit, so it seems odd that only I have this issue if it were supported. Other staff can use my login from their Linux (Gentoo, as if that matters) systems (again, 32 bit).

I used my gaim client to connect and it also logs me in with the correct information supplied and I see a user list, too–everything appears to be working. The problem is, I am kicked off within seconds with the message:

manager.chat.domain.com: You are using an invalid client, and therefore will be disconnected. Please ask your system administrator for client choices.

So, that’‘s not really an option, I guess. I do not have access to the server to set clients that are allowed, unfortunately, so I’‘m stuck. Apparently I need this for work as a newly required IM chat interface and am having the above problems. I’'ve never used this software and have no idea where do go with this, so any insight is appreciated.

I use no firewalls on the router/system when testing, and I’‘ve just now found the error log (I don’‘t have a ton of time to mess with this, unfortunately). The log shows (as I start it, switch to "free to chat’’ and back to “online” for the status:

$ tail -f error.log

Exception in thread “Thread-1” java.lang.UnsatisfiedLinkError: /home/tim/Spark/lib/linux/libtray.so: /home/tim/Spark/lib/linux/libtray.so: cannot open shared object file: No such file or directory

at java.lang.ClassLoader$NativeLibrary.load(Native Method)

at java.lang.ClassLoader.loadLibrary0(Unknown Source)

at java.lang.ClassLoader.loadLibrary(Unknown Source)

at java.lang.Runtime.loadLibrary0(Unknown Source)

at java.lang.System.loadLibrary(Unknown Source)

at org.jdesktop.jdic.tray.internal.impl.GnomeSystemTrayService.(Notifications.java :87)

at org.jivesoftware.spark.SparkManager.getNotificationsEngine(SparkManager.java:22 6)

at org.jivesoftware.spark.Workspace.buildLayout(Workspace.java:194)

at org.jivesoftware.LoginDialog.startSpark(LoginDialog.java:743)

at org.jivesoftware.LoginDialog.access$600(LoginDialog.java:81)

at org.jivesoftware.LoginDialog$LoginPanel$1.construct(LoginDialog.java:507)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:132)

at java.lang.Thread.run(Unknown Source)

$ ls -la /home/tim/Spark/lib/linux/libtray.so

-rwxr-xr-x 1 tim tim 19779 Oct 30 11:06 /home/tim/Spark/lib/linux/libtray.so

More error.log:

at org.jdesktop.jdic.tray.internal.ServiceManager.getService(Unknown Source)

at org.jdesktop.jdic.tray.SystemTray.(Notifications.java:87)

at org.jivesoftware.spark.SparkManager.getNotificationsEngine(SparkManager.java:22 6)

at org.jivesoftware.spark.SessionManager.changePresence(SessionManager.java:228)

at org.jivesoftware.spark.ui.status.StatusBar$3$1.construct(StatusBar.java:177)

at org.jivesoftware.spark.util.SwingWorker$2.run(SwingWorker.java:132)

at java.lang.Thread.run(Unknown Source)

$ ldd /home/tim/Spark/lib/linux/libtray.so

linux-gate.so.1 => (0xffffe000)

libdl.so.2 => /lib/libdl.so.2 (0xf7fc7000)

librt.so.1 => /lib/tls/librt.so.1 (0xf7fb3000)

libpthread.so.0 => /lib/tls/libpthread.so.0 (0xf7fa1000)

libXt.so.6 => /usr/X11R6/lib/libXt.so.6 (0xf7f50000)

libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0xf7e71000)

libc.so.6 => /lib/tls/libc.so.6 (0xf7d47000)

/lib/ld-linux.so.2 (0x56555000)

libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0xf7d3d000)

libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0xf7d25000)

Anyone? Any ideas at all?

I wish I could offer some help, but I’‘m in the exact same boat as you. I’‘d give anything (within reason) to get Spark running in OpenSuse 10.1 64-bit. Spark works great on my 32bit hosts (Win32 + OpenSuse), but does exactly what you described in 64 bit. I’'m at a loss, as I would very much like to switch my IM infrastructure to Wildfire + Spark, but without 64 bit support this cannot happen.

After doing some more research I think I know what the problem is. Perhaps someone smarter than me can offer a suggestion (I’‘d be glad to figure it out myself, just don’'t hold your breath for me to come to the right answer).

Spark relies on JDIC (java desktop environment stuff) to provide features such as system tray icon. JDIC is built for 32-bit. I’'ve found very little on getting JDIC to compile and install in a 64-bit environment. Let me just say that the fact that Spark will even START and show anything without JDIC is a testament to the developers of Spark - most apps that require JDIC simply die upon initialization in a 64-bit environment.

So, where does this leave us…

  1. Someone here may have found a good method of getting JDIC to compile in 64-bit Linux. If you have, please share. I’‘d be glad to help debug things, and I have made some progress… but still can’'t finish the compile.

  2. Perhaps the next (or the one after it) version of Spark will not use JDIC. As much as I can hope, I think this is unrealistic to imagine.

  3. People like me continue to use Kopete with Wildfire and envy our 32-bit brethren who use Spark (and can bloody well transfer files without an error).

If anyone else is interested in working together on getting JDIC to play 64-bit, drop a message in this thread. Otherwise, I’'m going to stick with Kopete and send some Euros to KDE to see if they can beef up file transfer compatibility w/ Wildfire using Kopete.

So I’‘ll do some research and see if I can get any help from the JDIC guys. I’'ll keep this forum updated with progress.

However, for now I’'ve gone ahead and filed an issue: SPARK-448.

Cheers,

Derek

Hi Derek,

one hopes that Java 1.6 solves this problem and if it doesn’‘t there’'s also the SysTray-as-Plugin issue which would be a workaround for it.

LG

ddman,

I fail to see the relation between the bug you referenced and this issue. The Linux client essentially dies before launching due to the lack of appropriate JDIC tray icon support. The client does, however, launch, but is essentially neutered in all ways. We are able to login, but cannot see any menus except preferences nor can we see other users who should be on our roster.

I’'ve tried several times to modify JDIC to compile on my OpenSuse 10.1 and 10.2 hosts with little luck. Could you perhaps check for OS type and architecture (check for Linux, then fire off a “uname -p”) - in cases where uname -p results in x86_64 do not use tray icon, nor attempt to load it. This may get past part of the issue, at the obvious cost of some functionality. I am unsure how much of the rest of Spark relies upon JDIC…

Yeah, different issue. I had to search to find this old post. I have no errors with anything, it just is essentially blank. Unfortunately the company I contract out to requires Spark (long story) due to their employee’‘s in the local office, and I can’‘t communicate with anyone in the office unless I have Spark. Jabber was set up to allow gaim as a valid/allowed client, but each time someone updates Jabber, the configuration is lost, so I have to wait and hopefully they won’'t complain that I “just have to get Spark to work”.

This requirement is not in my contract, so AIM, Yahoo IM, ICQ, etc. are fine and those or email can be used when it comes down to it, but it’‘s still a bit of a hassle with all of these issues. This software has way too many bugs for me to ever want to use without being forced to. Hopefully gaim will be allowed again soon and I can put this shoddy software behind me. I’‘ve tried all of the newest versions, various tweaks, forcing it to run in 32 bit and I just give up. I’'m not going to try and download and fix the source code of Spark for these reasons either.

Download VMWare Player and run it on a 32 bit Virtual Machine?

Horrible, I know. But It’'d work.

Im not 100% sure if this is related, but if you use some X composting options, Java AWT drawing can get messed up. So if you use the XRENDER, Composite, or related options (for Beryl, or things like it) some Java windows will show up blank. The work around is to make sure you have Motif installed, then set the envrionment variable AWT_TOOLKIT to MToolkit . (’‘export AWT_TOOLKIT=MToolkit’’)

Hi,

finally Derek did create SPARK-763 (SPARK-373) and scheduled it for Spark 2.5.4, one may want to vote for this issue.

LG