powered by Jive Software

Docs state that it requires JDK 1.5. Is the JRE 5.0 ok to use...?

Stupid question #5241 by me

I currently have

C:\Documents and Settings\Administrator>java -version

java version “1.4.2_06”

Java™ 2 Runtime Environment, Standard Edition (build 1.4.2_06-b03)

Is Java™ 2 Runtime Environment Standard Edition 5.0 okay to install? Does it really need the JDK instead of the JRE, or is that (JDK) just for Smack or other addons?

Thanx…

please excuse my ignorance

Michael,

Yes, JDK 1.5 is ok to install. Here’‘s a tip – set a JAVA_HOME environment variable in Windows and have that point to the JDK you want to use. For example, if you have 1.4.2 and 1.5.0 installed at c:\jdk\1.4.2 and c:\jdk\1.5.0 respectively then set JAVA_HOME to whatever one you want to use all the time. Then, if you’'re going to run or develop Messenger, set open a command prompt and set the JAVA_HOME equal to the 1.5 location (you can also modify the Messenger startup.bat script for this).

Bottom line is that Messenger needs JDK 1.5 to run but you can install 1.5 and have it coexist with other VMs.

Cheers,

–Bill

Thanks for the information.

Yeah, I already knew about java_home but thanks for those who didn’'t.

One of our other apps on that machine requires 1.4.2 line right now… figured this might be a problem… but I’'m sure it will all go well.

Cheers!

is jdk 1.5 absolutely required? i can’'t be the only one who finds that requirement restrictive? can it be run on 1.4.x? are we otherwise relagated to the old version of jive if 1.4.x is our jdk of choice?

JDK 1.5 is required for Jive Messenger 2.x. The only major platform that 1.5 is not available for yet is Mac OS X (will be avail for OS X Q1 2005). Is there a reason you can’'t install the latest JDK?

Regards,

Matt

there are various reasons…most significantly, that jdk 1.5 has only been out for a month and a half. swapping out jdk 1.4.x for 1.5 in a production environment is just not feasible. and running dual jdk’‘s for the sole purpose of supporting jive isn’'t ideal for both technical and business reasons.

imo, it’‘s a mistake to require 1.5. i think developers/users might shy away from the product for the simple fact that a widely accepted/stable jdk like 1.4 isn’'t even on the map.

are the old binaries of the last version (1.1) even available anymore? i would need these since they support the older jdk…otherwise, i guess i’'m outta luck with jive.

JDK 1.5. is not stably and natively available for the *BSD platforms, either. FreeBSD can, I think, run a Linux version in compatibility mode, but that’'s not necessarily something that you want to do.

I also think that the use of jdk 1.5 is a bit early. But on the other hand is’'s a good opportunity to get in contact with java 1.5 as it offers a lot of cool new features (in a few month you have to do this anyway). And for those how dont wont to go with it on the productive machines just take an other machine and give it a try. Messenger is a really cool piece of software that you should try which jdk ever you have to use.

guido

Hey all,

I’'ll summarize our position…

  • The JDK 1.5 requirement is somewhat “early” by standard measurements. However, not requiring 1.5 now would mean that we couldn’'t reasonably require it for a very long time since there would be a large established user base of Messenger users on 1.4.

  • We believe that using 1.5 will be a key to Messenger’'s success. Already, the new Java release has let us vastly simplify a lot of code, increase scalability, and fix numerous bugs. It will greatly simplify implementing SASL and in-stream TLS in the near future.

  • JDK 1.5 is already available for what must be 98% of commonly deployed environments (Windows, Linux, Solaris). Mac OS X support will follow soon.

  • We’'ll put the Messenger 1.1 release back up (will try to do that today). However, that release is pretty lacking compared to the new 2.x code.

Best Regards,

Matt

i understand and appreciate the jive developer’‘s position…it’'s always a slow crawl to move up to the next version of the jdk.

i think the people who use jive for personal use will have no problem with 1.5…i certainly wouldn’'t. but for those who wish to use it in a business environment (like myself), i think 1.5 is going to slow adoption, even though it will good for the product long term. again, just my opinion.

i appreciate the help. and thanks for planning to put 1.1 backup.

i understand and appreciate the jive developer’'s

position…it’'s always a slow crawl to move up to the

next version of the jdk.

Yep. Honestly, we like pushing the boundaries with Open Source software.

i think the people who use jive for personal use will

have no problem with 1.5…i certainly wouldn’'t. but

for those who wish to use it in a business

environment (like myself), i think 1.5 is going to

slow adoption, even though it will good for the

product long term. again, just my opinion.

I would agree if installing Messenger into an existing J2EE app-server. In that case, it can be disruptive to upgrade the app-server to a new VM and backwards compatability needs to be considered very carefully. However, I totally disagree when doing a standalone deployment. It’'s very possible to have a non-shared VM instance just for Jive Messenger – in that case the JDK version is 100% irrelevant. The Messenger install along with 1.5 becomes a “single application” that is isolated from everything else in the environment. Any IT department that has policies to the contrary simply has not thought through the issues correctly.

Regards,

Matt

P.S. – If anyone is truly prevented from using Jive Messenger due to the JDK 1.5 requirement, we feel for you and hope that the situation doesn’‘t last long. Hopefully you’'ll be able to become a Jive Messenger user in the near future!

Regards,

Matt

I understand your position. Unfortunately, I am one of the few percentages of people who use Mac OS X. One of the goal for any open-source project is to get as many people to involve as possible. It’‘s a pity that Mac OS X users won’'t be able to use Jive Messenger 2.x until Q1 2005.

Until then…I would try Jive Messenger on a Windows machine then.

Tony

  • We’'ll put the Messenger 1.1 release back up (will

l try to do that today). However, that release is

pretty lacking compared to the new 2.x code.

matt, any word on getting 1.1 available again? it’'s critical for me to have access to those binaries, hopefully within the next week or so.

I keep pinging the guy who will be doing the work to put them back up, but he’‘s been very busy. I’'ll forward him this thread though.

-Matt

Just a little information for those bucking the 1.5 upgrade. The code base in 1.5 is sooo much cleaner and more efficient that in 1.4.2, and faster. We’'ve found no problems with backward compatibility… with any well written code. In fact, quite the opposite. I would highly suggest that those who think they have problems with the update, setup a dev server and actually test it out. I know that several applications which “think” they need 1.4.2 are very happy with 1.5

(not a part of the Jive team, just part of a different development team with other java projects)

FYI, the 1.1 binaries are now available:

http://www.jivesoftware.org/downloads-archived.jsp

Regards,

–Bill

bill,

didn’'t there used to be a 1.1 version for mac osx? can you make that available as well? thanks.

Dan,

Sorry for the oversight – it’'s up there now.

Cheers,

–Bill