powered by Jive Software

Does openfire must working on 32-bit JDK?

hi,

my OS is win8 64bit, installed JDK1.7 64-bit. and set java_home to this JDK1.7.

installed openfire 3.9.1.

when i run openfire.exe will get below error.

The JAVA_Home environment variable does not point to a working 32-bit JDK or JRE.

hm… openfire does not support 64-bit JDK?

1 Like

can you paste the ouput of:

(from cmd prompt)

C:> echo %PATH%

C:> echo %JAVA_HOME%

Thanks for you so quickly feedback.

Here is my envirnment info.

C:\echo %JAVA_HOME%

C:\Program Files\Java\jdk1.7.0_07

C:\echo %PATH%

C:\PROGRAM FILES (X86)\INTEL\ICLS CLIENT;C:\PROGRAM FILES\INTEL\ICLS CLIENT;C:

\windows\SYSTEM32;C:\windows;C:\windows\SYSTEM32\WBEM;C:\windows\SYSTEM32\WINDOW

SPOWERSHELL\V1.0;;C:\PROGRAM FILES\INTEL\INTEL® MANAGEMENT ENGINE COMPONENTS\

DAL;C:\PROGRAM FILES\INTEL\INTEL® MANAGEMENT ENGINE COMPONENTS\IPT;C:\PROGRAM

FILES (X86)\INTEL\INTEL® MANAGEMENT ENGINE COMPONENTS\DAL;C:\PROGRAM FILES (X8

6)\INTEL\INTEL® MANAGEMENT ENGINE COMPONENTS\IPT;C:\PROGRAM FILES (X86)\INTEL\

OPENCL SDK\2.0\BIN\X86;C:\PROGRAM FILES (X86)\INTEL\OPENCL SDK\2.0\BIN\X64;C:\PR

OGRAMDATA\LENOVO\READYAPPS;C:\PROGRAM FILES (X86)\COMMON FILES\ACRONIS\SNAPAPI;

C:\Program Files\ThinkPad\Bluetooth Software;C:\Program Files\ThinkPad\Bluetoot

h Software\syswow64;;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Prog

ram Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program Files\Intel\WiFi\bin;C:

\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files\Intel\WiFi\bi

n;C:\Program Files\Common Files\Intel\WirelessCommon;C:\Program Files\Java\jdk

**1.7.0_07\lib;C:\Program Files\Java\jdk1.7.0_07\bin;**C:\MySQL5.6\bin

try setting JAVA_HOME to point at the /bin directory (<-- may not work)

does not work yet, got the new error below

No JVM could be found on your system.

Please define exe4j_java_home to point to an installed 32-bit JDK or JRE…

I think i have to install 2 JDK, 32-bit and 64-bit, 32-bit JDK only for my openfire

it works fine after i install a 32-bit JDK again, and set exe4j_java_home to this 32-bit JDK. openfire runs well now.

anyway, Thank you Jason.