powered by Jive Software

Domain Issue

When using “im.mydomain.com” as my server name, everything works just fine. However, if I use simply “mydomain.com” (which I’d prefer), server-to-server communication does not work.

Any ideas?

Thanks,

Josh

Let me just provide some more details…

The server is behind a firewall. Both “mydomain.com” and “im.mydomain.com” point to the firewall, which redirects all XMPP traffic to the server. I can’t see a reason why it wouldn’t work either way. The strange part is that inter-server communication works fine either way; only server-to-server communication breaks when using simply “mydomain.com”.

Hope this helps clear up my question.

Thanks,

Josh

your dns records need to be configured properly and openfire must be configured to have that as the xmpp.domain and server name. Specifically look at your SRV records.

Hmm. I’m not sure I follow. Define “properly”.

Like I said, it is working with “im.mydomain.com”, and the DNS entries for “im.mydomain.com” and “mydomain.com” are identical.

Thanks for the reply.

Josh

Do you control both servers you want to connect via server-2-server? What are the security settings? Maybe this connection requires SSL and certificates were generated for im.mydomain.com. Do you see any realted errors in both servers’ logs?