powered by Jive Software

Downgrade OF from 4.03 to 4.01

Hello to all,

I was upgrading my OF Server on Ubuntu 14.02 from Version 4.01 to 4.03. Still Using 1.7 Java! We do use Spark Client Version 2.7x. Before the update everything worked fine, now some users get dropped and I am honestly dont know why!

My plan is to downgrade OF to Version 4.01 again! Is that possible? I do use the embeddet Database!

Thanks in advance for a hint…

cheers, Pentecost

It should be possible . The actual procedure will depend on the way Openfire is installed (tar.gz, deb).

Why not update to Java 8?

Hi wroot, well… I will give Java 8 a try and if the problems still persist after that I need to downgrade I guess!

I always installed OF from a *.deb file! What do I have to do to start downgrading then?

Thanks wroot for your help…

Cheers

Uninstall current one How to uninstall a .deb package? - Ask Ubuntu and install 4.0.1 www.igniterealtime.org/downloads/download-landing.jsp?file=openfire/openfire_4. 0.1_all.deb

will it keep the configuration? I already have about 300 users, which I don´t wanna lose… :slight_smile:

It should keep the configuration and database. But it is better to make a backup before doing this

Hey wroot, Java 8 is installed now! How do I make OF use that version? Restarting the server didn´t work!

Openfire shows on the first screen of Admin Console which Java is in use. Does it show Java 7 there? Then maybe you need to uninstall Java 7.

Or https://community.igniterealtime.org/message/259630#comment-259630