powered by Jive Software

Dumb newbie with java libjli.so probelm (fedora 6 rpm install)

./openfire.sh

…/openfire/jre/bin/java: error while loading shared libraries:

libjli.so: cannot open shared object file: No such file or directory

OK libjli is part of java ee which i installed from the sun website but which file do i update to get openfires java jre to get the file, im assuming this is classpath issue

This is the

latest 3.3.2.1.i386.rpm im installing from

This site seems to be rather cyptic on install problems

Excuse my stupidness.

Hi,

for me it seems like the Openfire installation is not complete and you are using the JRE which is delivered within the rpm packet. You could try to install it again and look for errors.

Or use the tar.gz file which uses your JRE, installation is described for example in Linux Installation Guide.

LG

Thank you - there does not seem to be much point to that rpm, I do hope the tar.gz will be less cryptic and have proper instructions rather than just millions of README files containing well not much.

‘one more time…’

OK resolved ! the tar.gz fixed the issue

Seriously that rpm is a waste of time

Thank you