Hi All!

I’ve found, that e-mail service in Openfire can’t send non-Latin characters correctly. It is becouse of iso-8859-1 is hardcoded :

EmailService.java: 173

String encoding = MimeUtility.mimeCharset(“iso-8859-1”);

I think it would be good to change this to “UTF-8”, or make this as configuration property.



I see, nobody do anything

Openfire 3.5.1 still have this bug.

When Fastpath plugin send transcription back to user, all non-latin characters changed to “?” sign :_|

I resolve this problem. It’s not enough change this parameters, but need to make some additional setting.

Unfortunately, even latest night builds not resolve problem, so I make my own patch (hope it will be included to stream)

My patch is attached to message. I test it with fastpath+webchat: it work!
openfire_email_utf8.patch (2118 Bytes)