powered by Jive Software

Empty Spark Window Frame

Hi Guys,

On a couple of machines I get a strange error whereby the spark instant messenger starts but only opens an empty window frame. There’s no roster or anything - you can see right through to the desktop background. This doesn’t happen all the time, but is fairly common on a couple of machines. We’ll often find that even if it has been working ok on a particular machine, sometimes you’ll open spark a bit later in the day and find it in this “empty” state again.

I’m using the spark_2_5_8.msi with openfire Openfire 3.6.4. I’ve implemented SSO which seems to work flawlessly (except when we see this issue).

I’ve rolled out spark to about 6 machines as a test, They all identical though they are in use all of the time so have various bits of software installed. They are all running Vista Enterprise 64bit. This error only seems to happen on a couple of the machines.

In the c:\Users\user.name\Spark\logs\errors.log on the affected machines is the following…

Jun 10, 2009 8:58:59 AM org.jivesoftware.spark.util.log.Log error
SEVERE:
java.net.SocketException: Software caused connection abort: recv failed
at java.net.SocketInputStream.socketRead0(Native Method)
at java.net.SocketInputStream.read(Unknown Source)
at java.io.BufferedInputStream.fill(Unknown Source)
at java.io.BufferedInputStream.read(Unknown Source)
at org.apache.commons.httpclient.HttpParser.readRawLine(HttpParser.java:77)
at org.apache.commons.httpclient.HttpParser.readLine(HttpParser.java:105)
at org.apache.commons.httpclient.HttpConnection.readLine(HttpConnection.java:1113)
at org.apache.commons.httpclient.HttpMethodBase.readStatusLine(HttpMethodBase.java :1832)
at org.apache.commons.httpclient.HttpMethodBase.readResponse(HttpMethodBase.java:1 590)
at org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:995)
at org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDir ector.java:395)
at org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirect or.java:170)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:396)
at org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:324)
at org.jivesoftware.sparkimpl.updater.CheckUpdates.isNewBuildAvailableFromJivesoft ware(CheckUpdates.java:150)
at org.jivesoftware.sparkimpl.updater.CheckUpdates.newBuildAvailable(CheckUpdates. java:94)
at org.jivesoftware.sparkimpl.updater.CheckUpdates.checkForUpdate(CheckUpdates.jav a:391)
at org.jivesoftware.MainWindow$11.finished(MainWindow.java:571)
at org.jivesoftware.spark.util.SwingWorker$2$1.run(SwingWorker.java:136)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

If anyone has any Idea’s as to why this is happening and how I could fix it, I would very grateful.

I suggest not to use msi installs provided on the site. Try to uninstall it completely from the Program Files and also delete the user profile. Then install the EXE version and see if that helps.

Hi wroot,

Thanks for the response, we’ve now tried as you suggested but unfortunately we still get the same result

Interestingly, one of our users who has experienced this issue has tried running the application in XP SP2 Compatibility mode with much more successful results. However, this has the effect of disabling his aero desktop which we don’t really want.

Has anyone else seen this kind of issue?

Just an update for those that are interested…

When we rolled out spark, we made sure that the “Preferences”>“Appearance”>“Use System Look and Feel” was enabled by default. Our most affected user has tried switching this off and restarting his spark client. He has so far had a 100% success rate with restarts. Is it possible that there could be a bug with this function? Has anyone else experienced this issue with when they had this feature enabled?

We would like to use system look and feel if at all possible…

KevinW wrote:

We would like to use system look and feel if at all possible…

As i understood, those who are using system look and feel doesnt have these problems with an empty frame? Then of course you can use system look and feel, if this is satisfying your needs.

Can’t say whether this blue theme (Synthetica) is causing the problem, but it sure has some other issues. E.g. resizing broadcast window while using blue theme will make broadcast window maximize beyond the screen. maybe this theme should be removed or replaced by something. Though it looks way better to me than the system look and feel

Thanks for the reply wroot,

I think at least one of us here is getting confused (it could just be me)… So I’ll just clarify my issue if that’s ok?

Our test group has “Enable system look and feel” set to “on” by default.

Around 25% of our test group experience the “blank window” problem (which is intermittent), the other 75% of the group have no problems.

One of our users experiences this “blank window” issue almost every time he starts spark, but since he has changed the “Enable system look and feel” checkbox to “off” he no longer experiences this issue.

We would prefer to use the system look and feel if we could so that spark appeared more integral with the operating system design.

I was wondering if there was a bug which occurred when the “Enable system look and feel” was set to “on” and if anyone else had experienced anything similar.

Hope this is ok?

Yeah, i got you wrong As i’m not using system look and feel i cant say anything about this issue. Maybe i should try to use it a bit.