Error after upgrade to mysql5

Hi, I have wildfire(mysql db) 2.4 in a debian sarge box. My problem is that after upgrading to a mysql 5 my service stopped working.

When I start the server I get this in error.log:

2007.01.16 17:44:37 [org.jivesoftware.database.ConnectionPool.(] Failed to create new connections on startup. Attempt 0 of 3

com.mysql.jdbc.CommunicationsException: Communications link failure due to underlying exception:


I tried to install wildfire 3.1 but I get similar errors.

I have a manually installed java and put the mysql connectors in:


It used to work with mysql-connector-java-3.0.16-ga-bin.jar, I have tried also with mysql connector version 3.1.14 and 5.0.4.

Any idea of what can be wrong?


Hi Omar,

your database could be down or you did not configure a TCP port for it or something completely different goes wrong. The “(snip)” part of your log file is the interesting one so you should post it here.


I have something like this:


MESSAGE: Connection refused

STACKTRACE: Connection refused

at com.mysql.jdbc.StandardSocketFactory.connect(

at com.mysql.jdbc.MysqlIO.(

at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)

at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessor

at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructor

at java.lang.reflect.Constructor.newInstance(

at java.lang.Class.newInstance0(

at java.lang.Class.newInstance(

at org.jivesoftware.wildfire.starter.ServerStarter.start(

at org.jivesoftware.wildfire.starter.ServerStarter.main(

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

at sun.reflect.NativeMethodAccessorImpl.invoke(

at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.ja va:25)

at java.lang.reflect.Method.invoke(

at com.exe4j.runtime.LauncherEngine.launch(Unknown Source)

at com.install4j.runtime.Launcher.main(Unknown Source)


I checked and my login, host and password is working well from the shell.

Any idea why? Is that enough to debug?


Hi Omar,

“Connection refused” is the problem. I assume that you did configure port 3306 in conf/wildfire.xml within your database connection string. And it seems that this port is not open, so you need to modify your MySQL configuration. I’'m not a MySQL expert but as far as I know there is a “file socket” mode and a “TCP socket” mode or something like this so it seems that MySQL is currently only using a file socket.

Does “netstat -an|grep 3306” show that this port is open?

Does this match conf/wildfire.xml or did MySQL4 use another port?


The port is opened, I can telnet to it and other applications can access to it in port 3306.

The thing is, I restarted mysql and all all is working again…

I dont know what happened, I guess it was an upgrade issue.

Thanks a lot.