powered by Jive Software

Error configuring mysql

i’'m installing the jive with mysql.

i was able to create a database named jive and i execute the .sql to create the tables.

i connect in the mysql (mysql -u root -p) and see the content of the tables, with user “root” and the password. everything looks fine, but when i go to configure the mysql in the web (127.0.0.1:9090), it show this error: " A connection to the database could not be made. View the error message by opening the “/logs/error.log” log file, then go back to fix the problem."

the conection is “jdbc:mysql://172.26.51.8:3306/jive”, and the username and the passwords are correct. anyone have an idea what’'s going on?

Hi,

What does the error log say? It will probably give you enough information to figure out the problem.

Conor.

One wild guess: The default mysql installation might not listen on anything other than localhost - or even use only sockets.

Have a look at your my.cnf and search for something like “skip-networking” or “bind-address”.

mysql -u root -p uses the local server as default and might use either 127.0.0.1 or the pipe/socket, whereas your JDBC url contains a different IP…

Regards,

Ben

there is in my.cnf


#skip-networking

server-id = 1


i’'ve tryied to comment server-id and to put = 0 but neither way it gets right.

i searched over the google but all that i found is the option “–skip-networking” to not listen for connections on 3306, but i didn’'t found what to do for listen to 3306. any help?

searching more, i found that:

http://www.advenio.com/phpbb2/viewtopic.php?t=2

thanks for all the help.

Yes, mysql distinguishes between users from localhost and users from anywhere else… doh

Well, please don’‘t mess with the mysql tables. The last line in that post is the right thing to do: GRANT/REVOKE should be used for privileges to avoid messing up the database and because you don’‘t need to tell mysql that you fiddled around with it’'s internal things.

Btw: You can, if you really think that it’'s a good idea to mess with mysql/users, tell mysql to use the modified settings without mysqladmin or restarting: Just type “flush privileges” in your mysql client…

Anyway: Glad you made it.