powered by Jive Software

Error connecting to the LDAP server

Hi All,

I have installed open fire 4.1.3 on Ubuntu 1404. When I integrate open fire to UCS LDAP it gives me below error.

Test: Connection Settings
Status: Error
Error connecting to the LDAP server. Ensure that the directory server is running at the specified hostname and port and that a firewall is not blocking access to the server.

Host:- gipl-ucs-001.gipl.inet
Port:- 389
Base DN:- OU=users,DC=GIPL,DC=INET

Please help me to find out this problem occurs.

Have you tried to disable firewall on the server with LDAP? Also, is the server’s name serving LDAP correct on the Host field?

try making your base dn the root of your domain dc=gipl,dc=inet

then for the admin dn just used the format username@gipl.inet

keep in mind the admin dn is a little miss leading. this is the account used to query ldap, and does NOT need to be an elevated account.

My firewall is already stopped.

It’s not working. I have tried so many options but the issue is not resolved.

Base DN: DC=GIPL,DC=INET Administrator DN: administrator@gipl.inet
Base DN: DC=GIPL,DC=INET Administrator DN: administrator@gipl
Base DN: DC=GIPL,DC=INET Administrator DN: CD=administrator
Is there any issue with MySQL? Because I am using MySQL database. But t connects perfectly.
Can I check that connection from the terminal?
Telnet is working with below command.
telnet gipl-ucs-001.gipl.inet 389

Try my Openfire config AD steps that are detailed at the bottom of: Openfire 4.2.1 a Active Directory 2008R2: First login fail, second login succeed

Cheers,
Cosmo

Sandip?! If this is the same sandeep Sharma that I have know for years let me know

@Nick_Giacopuzzi No, I am from Jaipur, India.

Hi all,
Now, I have solved login problem and openfire is login successful from the client side. I have use spark for client side. But it’s not showing users on the client side. It gives below error.

2018.04.05 16:12:32 ERROR [pool-monitoring2]: org.jivesoftware.openfire.reporting.stats.StatsEngine - Error sampling for statistic muc_users
org.jrobin.core.RrdException: Bad sample timestamp 1522924920. Last update time was 1522924920, at least one second step is required
at org.jrobin.core.RrdDb.store(Unknown Source)
at org.jrobin.core.Sample.update(Unknown Source)
at org.jivesoftware.openfire.reporting.stats.StatsEngine$SampleTask.run(StatsEngine.java:392)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)

2018.04.05 16:11:46 ERROR [socket_c2s-thread-2]: org.jivesoftware.openfire.roster.Roster - Groups ([team-system admin]) include non-existent username (cn=sandeep.sharma,cn=users,dc=gipl,dc=inet)

My friend is from India as well but lives here in the US now. Same exact
name spelling and all.

Have a nice day!