powered by Jive Software

Error installing plugin

hello community, I have an openfire server version 4.7.1, when installing any plugin the following error appears

2022.05.31 08:09:51 ERROR [Jetty-QTP-AdminConsole-1766]: org.jivesoftware.openfire.container.PluginManager - Error installing plugin ‘monitoring.jar’: Cannot parse file into a JAR format.

This suggests that you are trying to install a file that is not actually the plugin. How do you try to install the plugin? Where did you obtain the plugin jar file?

I download the plugin from the openfire website Ignite Realtime: Openfire Plugins

I suspect that something went wrong during the download. Maybe the file got corrupted?

I have done the process with several plugins and the same thing happens, I will try to download it again

If the problem persists, try to determine what file type the downloaded file is. Maybe look at the file size, or try to open the file as a text document. Look for any clues to find out if the plugin file actually is a plugin file (and not some kind of error message, or otherwise corrupted file).