Error - no access to admin panel on Debian Sarge


I have installed wildfire 3.1.1 on a Debian Sarge System.

I can start wildfire without any problems.

But I can`t access the admin panel (IP and Ports checked).

error.log says:

2007.01.02 23:14:48 org.jivesoftware.wildfire.container.PluginManager.loadPlugin( 467) Error loading plugin

java.lang.NoClassDefFoundError: org/apache/jasper/JasperException

at org.apache.jasper.EmbeddedServletOptions.(

at org.apache.jasper.servlet.JspServlet.init(

at org.mortbay.jetty.servlet.ServletHolder.initServlet(

at org.mortbay.jetty.servlet.ServletHolder.start(

at org.mortbay.jetty.servlet.ServletHandler.initializeServlets( :446)

at org.mortbay.jetty.servlet.WebApplicationHandler.initializeServlets(WebApplicati

at org.mortbay.jetty.servlet.WebApplicationContext.doStart(WebApplicationContext.j ava:509)

at org.mortbay.util.Container.start(

at org.mortbay.http.HttpServer.doStart(

at org.mortbay.util.Container.start(

at org.jivesoftware.wildfire.container.AdminConsolePlugin.initializePlugin(AdminCo

at org.jivesoftware.wildfire.container.PluginManager.loadPlugin( :406)

at org.jivesoftware.wildfire.container.PluginManager.access$200( :49)

at org.jivesoftware.wildfire.container.PluginManager$

at java.util.concurrent.Executors$ Source)

at java.util.concurrent.FutureTask$Sync.innerRunAndReset(Unknown Source)

at java.util.concurrent.FutureTask.runAndReset(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101 (Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodi c(Unknown Source)

at java.util.concurrent.ScheduledThreadPoolExecutor$ n Source)

at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)

at java.util.concurrent.ThreadPoolExecutor$ Source)

at Source)

Java Version is 1.5.0_06

Please help.




are you using Sun’'s JRE?


Hi All,

I had successfully installed the wildfire1_1_1 in my AIX machine.

But i am not able to login to the admin console.

when i try to open the admin login page in the browser .its showing the following message.

‘‘Language received from client: GET Setlocale: C WServer.HANDSHAKING 41730 WServer.HANDSHAKING’’


I had successfully installed the Wildfire1_1_1 in AIX machine.

I am not able to open the admin loging page in the browser.

I am getting following message.

Language received from client: GET Setlocale: C WServer.HANDSHAKING 41730 WServer.HANDSHAKING

Please help me.

Check your $PATH, I had that problem as well on my Debian “etch” system.

The problem is that GCC’‘s “gij” just-in-time interpreter is /usr/bin/java and is located in your path before Sun’'s JRE.

When I set my $PATH to have /usr/local/jre/bin (the where my copy of Sun’'s java jit interpreter resides) Wildfire started correctly.

Setting JAVA_HOME to the appropriate path - /usr/local/jre in my case - worked just as well.

Yes, i was using Suns JRE. After taking the Binaries with includet JRE it worked. (Sorry for my late answer - I wasn`t at home for a few days).

Hi Deepak,

I think you still have the other thread open regarding AIX and I’‘ve seen this error on AIX with JDK half a year ago. I did not try Wildfire on AIX again as I couldn’‘t get any help here. IBM did release 3 updates up to now so maybe it does work with the current JDK, maybe it doesn’'t.