powered by Jive Software

Error on windows 2003 - MySQL 4.0.20a-nt-max

I’‘m not sure what is causing my error but here is the error I’'m getting from my log file when installing:

Can anyone help?

2005.06.03 17:53:15 [org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:106)

] Failed to create new connections on startup. Attempt 0 of 3

java.sql.SQLException: Data source rejected establishment of connection, message from server: “Host ‘‘server.local’’ is not allowed to connect to this MySQL server”

at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:649)

at com.mysql.jdbc.Connection.createNewIO(Connection.java:1786)

at com.mysql.jdbc.Connection.(Connection.java:450)

at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:411)

at java.sql.DriverManager.getConnection(Unknown Source)

at java.sql.DriverManager.getConnection(Unknown Source)

at org.jivesoftware.database.ConnectionPool.createCon(ConnectionPool.java:412)

at org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:83)

at org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionProv ider.java:83)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:263)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:269)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2005.06.03 17:53:25 [org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:106)

] Failed to create new connections on startup. Attempt 1 of 3

java.sql.SQLException: Data source rejected establishment of connection, message from server: “Host ‘‘server.local’’ is not allowed to connect to this MySQL server”

at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:649)

at com.mysql.jdbc.Connection.createNewIO(Connection.java:1786)

at com.mysql.jdbc.Connection.(Connection.java:450)

at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:411)

at java.sql.DriverManager.getConnection(Unknown Source)

at java.sql.DriverManager.getConnection(Unknown Source)

at org.jivesoftware.database.ConnectionPool.createCon(ConnectionPool.java:412)

at org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:83)

at org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionProv ider.java:83)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:263)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:269)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2005.06.03 17:53:35 [org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:106)

] Failed to create new connections on startup. Attempt 2 of 3

java.sql.SQLException: Data source rejected establishment of connection, message from server: “Host ‘‘server.local’’ is not allowed to connect to this MySQL server”

at com.mysql.jdbc.MysqlIO.doHandshake(MysqlIO.java:649)

at com.mysql.jdbc.Connection.createNewIO(Connection.java:1786)

at com.mysql.jdbc.Connection.(Connection.java:450)

at com.mysql.jdbc.NonRegisteringDriver.connect(NonRegisteringDriver.java:411)

at java.sql.DriverManager.getConnection(Unknown Source)

at java.sql.DriverManager.getConnection(Unknown Source)

at org.jivesoftware.database.ConnectionPool.createCon(ConnectionPool.java:412)

at org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:83)

at org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionProv ider.java:83)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:263)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:269)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2005.06.03 17:53:45 [org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionPro vider.java:88)

]

java.io.IOException

at org.jivesoftware.database.ConnectionPool.(ConnectionPool.java:118)

at org.jivesoftware.database.DefaultConnectionProvider.start(DefaultConnectionProv ider.java:83)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:263)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:269)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2005.06.03 17:53:45 [org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConne ctionProvider.java:68)

] Warning: DbConnectionDefaultPool.getConnection() was called before the internal pool has been initialized.

2005.06.03 17:53:45 [org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnecti onManager.java:279)

]

java.lang.NullPointerException

at org.jivesoftware.database.DbConnectionManager.setMetaData(DbConnectionManager.j ava:420)

at org.jivesoftware.database.DbConnectionManager.setConnectionProvider(DbConnectio nManager.java:268)

at org.jivesoftware.messenger.admin.setup_002ddatasource_002dstandard_jsp._jspServ ice(setup_002ddatasource_002dstandard_jsp.java:269)

at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:94)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:688)

at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:427)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:822)

at org.jivesoftware.util.LocaleFilter.doFilter(LocaleFilter.java:43)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.util.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingF ilter.java:41)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.jivesoftware.admin.AuthCheckFilter.doFilter(AuthCheckFilter.java:78)

at org.mortbay.jetty.servlet.WebApplicationHandler$CachedChain.doFilter(WebApplica tionHandler.java:813)

at org.mortbay.jetty.servlet.WebApplicationHandler.dispatch(WebApplicationHandler. java:494)

at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:569)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1482)

at org.mortbay.jetty.servlet.WebApplicationContext.handle(WebApplicationContext.ja va:624)

at org.mortbay.http.HttpContext.handle(HttpContext.java:1434)

at org.mortbay.http.HttpServer.service(HttpServer.java:896)

at org.mortbay.http.HttpConnection.service(HttpConnection.java:814)

at org.mortbay.http.HttpConnection.handleNext(HttpConnection.java:981)

at org.mortbay.http.HttpConnection.handle(HttpConnection.java:831)

at org.mortbay.http.SocketListener.handleConnection(SocketListener.java:244)

at org.mortbay.util.ThreadedServer.handle(ThreadedServer.java:366)

at org.mortbay.util.ThreadPool$PoolThread.run(ThreadPool.java:534)

2005.06.03 17:53:45 [org.jivesoftware.database.DefaultConnectionProvider.getConnection(DefaultConne ctionProvider.java:68)

] Warning: DbConnectionDefaultPool.getConnection() was called before the internal pool has been initialized.

2005.06.03 17:53:45 [org.jivesoftware.database.DbConnectionManager.getConnection(DbConnectionManage r.java:107)

] WARNING: ConnectionManager.getConnection() failed to obtain a connection.

Hi handband2,



That sounds like a MySQL permissions issue, take a look at this thread for details.



Hope that helps,

Ryan

ryang,

Thanks for the response but I found that thread earlier and checked all my permissions.

The same user I’‘m using for Jive is being used in another application and the other application works fine. I even tried with root user which seems to work on everything and I’'m still getting the same error.

thanks,

handband2

Hi handband2,

Hmm… what version of Messenger are you using? I’'m not familiar with Windows 2003, is it possible there is some security setting that is blocking Messenger from connecting to MySQL?

Thanks,

Ryan

Ryan,

I’‘m using the latest version (Jive Messenger 2.1.4). I’‘m checking the security settings but I’'m thinking something might be wrong with my JDBC Driver. Could this be creating the error?

Also, is there a way to check to see if the driver is working correctly?

Thanks,

Vince

Hi Vince,

I’'m using the latest version (Jive Messenger 2.1.4).

I’‘m checking the security settings but I’'m thinking

g something might be wrong with my JDBC Driver.

Could this be creating the error?

I was wondering about that too. You might want to try downloading the latest driver (I’'m not entirely sure which one comes with Messenger) and give that a shot:

http://dev.mysql.com/downloads/

Also, is there a way to check to see if the driver is

working correctly?

Not that I know of. I guess you could write a program that uses it and see if you have any problems, but I’'d try downloading and uses the latest version of the driver first.

~Ryan

Here is the key to your stack trace: + java.sql.SQLException: Data source rejected establishment of connection, message from server: “Host ‘‘server.local’’ is not allowed to connect to this MySQL server”+

I’'m guessing that you have the mysql server running on the same machine as jive messenger, correct?

This error is due to jive messenger trying to log in as username@server.local, instead of username@localhost. Doesn’'t matter that you typed in jdbc:mysql://localhost:3306/<jive_messenger_database> as I just found out (on linux). What you need to do is grant permissions in mysql for the username to log into the database server as username@server.local also.

Try this… log into your mysql server and issue the command: GRANT ALL ON <jive_messenger_database>.* TO ‘’<jive_db_user>’’@’‘server.local’’ IDENTIFIED BY ‘’<jive_db_user_password>’’;

Of course, replace anything in <>brackets with the appropriate values. The web interface should almost immediately connect to the mysql server and proceed to the next page.

NOTE: For linux users with this problem, it will be localhost.localdomain instead of server.local

–James

Thanks for all the help guys. The problem was fixed by correcting the JDBC Driver for MySQL.

Now that I’'ve been running it for a couple of days I have NOT had one problem This is a awesome piece of software!

Thanks again,

Vince

Hi Vince,

It’'s good to hear you were able to get things working. Which version of the driver did you end up using?

Thanks,

Ryan

Thanks for all the help guys.

Why not give some “helpful” or “correct” points to ryang in that case?

Regards,

Matt

Ryang, watch out!:slight_smile: You are almost going gold:)

Ryan,

I went with the newest version (Connector/J 3.1). I had J 3.0 setup but it seems the file where the driver was got moved so the variable value was incorrect. While I was fixing the value I decided to just update to the newest driver.

I agreed with matt to give you points for the help you did offer

Thanks again for your help!!

Vince

Ryang, watch out!:slight_smile: You are almost going gold:)

Uh, oh. Does that mean I have to turn Pro? Retire? Maybe I’'ll get my picture on a Wheaties box.

Hi Vince,

I went with the newest version (Connector/J 3.1). I

had J 3.0 setup but it seems the file where the

driver was got moved so the variable value was

incorrect. While I was fixing the value I decided to

just update to the newest driver.

Good to know. It’'s always nice to have the resolutions to these issues “documented” in the forums.

I agreed with matt to give you points for the help

you did offer

Thanks!

~Ryan