powered by Jive Software

Error or Fedora Linux

Hi folks

When I transfer files on 2.9.5 returns this error, its a knowing bug?

Linux enviromnent - Fedora

Mar 10, 2021 10:59:58 AM org.jivesoftware.spark.util.log.Log warning
WARNING: Not loading plugin TicTacToeas it is blacklisted.
Mar 10, 2021 10:59:58 AM org.jivesoftware.spark.util.log.Log warning
WARNING: Not loading plugin Translator Pluginas it is blacklisted.
Mar 10, 2021 10:59:58 AM org.jivesoftware.spark.util.log.Log warning
WARNING: Not loading plugin Reversias it is blacklisted.
Mar 10, 2021 10:59:59 AM org.jivesoftware.smack.AbstractXMPPConnection asyncGoLimited
INFO: 20 simultaneous executing runnables reached
Security framework of XStream not explicitly initialized, using predefined black list on your own risk.
Mar 10, 2021 11:00:01 AM org.jivesoftware.spark.util.log.Log error
SEVERE: Tray don’t supports on this platform.
Exception in thread “AWT-EventQueue-0” java.lang.NullPointerException
at org.jivesoftware.spark.filetransfer.SparkTransferManager.sendFile(SparkTransferManager.java:530)
at org.jivesoftware.spark.filetransfer.ChatRoomTransferDecorator$1.finished(ChatRoomTransferDecorator.java:154)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
at java.awt.EventQueue.access$500(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.awt.EventQueue$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

I have moved your question to another thread as it is not related to new skin of Spark. First warning can be ignored. I have opened a ticket regarding transfer error https://igniterealtime.atlassian.net/browse/SPARK-2225
But we historically lack developers working on Linux (or Mac), so don’t expect this to be fixed soon. If ever…