powered by Jive Software

Error running FastPath Setup

When running the FastPath setup (http://:<port_number>/webchat), upon entering the server host and port (5222) we get the following error. The server host is correct and port 5222 is open on the server (we used FastPath with the previous installation on the same server).

HTTP ERROR: 500

INTERNAL_SERVER_ERROR

RequestURI=/webchat/setup-finished.jsp
Caused by:

java.lang.NullPointerException
at org.jivesoftware.webclient.jsp.setup_002dfinished_jsp._jspService(setup_002dfin ished_jsp.java:74)
at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:97)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:820)
at org.mortbay.jetty.servlet.ServletHolder.handle(ServletHolder.java:487)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1093)
at org.jivesoftware.webchat.SetCharacterEncodingFilter.doFilter(SetCharacterEncodi ngFilter.java:45)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.jivesoftware.webchat.SetupFilter.doFilter(SetupFilter.java:92)
at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.ja va:1084)
at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:726)
at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:405)
at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollect ion.java:206)
at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:152)
at org.mortbay.jetty.Server.handle(Server.java:324)
at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
at org.mortbay.jetty.HttpConnection$RequestHandler.headerComplete(HttpConnection.j ava:829)
at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:514)
at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:211)
at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
at org.mortbay.thread.QueuedThreadPool$PoolThread.run(QueuedThreadPool.java:488)

I was able to get the setup to complete and get the prompt: “Webchat installation is now complete. To test your installation, click on the following image” The image is broken and the test pop-up just displays a close button.

Also, now in the admin console there is FastPath tab (but there is no text on it) and when I click on the tab it takes me to /webchat/ and the page dispalys:

"List of available workgroups within Fastpath

Click on one of the following workgroups to join."

But there are no workgroups listed.

try restarting the openfire server now. Give it a little as fastpath takes longer to load.

The Openfire server was restarted and the same problem is occuring. I tried deleting the plugin and reinstalling it, and then restarted the server - still the same issue.

Then either Openfire or fastpath is not configured correctly. To use fastpath openfire must be configured as such:

  • Server Name must be a Fully Qualified Domain Name (FQDN) resolvable via external DNS (e.x. chatserver.domain.com)
  • xmpp.domain system property must match the Server Name
  • Self Generated Certificates or Purchased certificates for openfire must match the Server Name
  • DNS a records must exist on external DNS for your Server Name
  • Chat ports need to be opened in your firewalls/routers (5222, 5223, 5269, and Possibly 9090 depending hosting location of the .war file)

Is the server host name and XMPP domain set the same? If not this is typically the cause, as you described these errors. Try using the webchat.war I provide (note you’ll need to rename plugin_webchat.war to webchat.war, then copy file into your openfire/plugins dir).

HTH,

http://www.igniterealtime.org/community/docs/DOC-1744