powered by Jive Software

Error starting HTTP Bind Service

Hi!
Help with OpenFire error, this morning the server didn’t work anymore

2019.08.01 11:04:37 ERROR [pool-5-thread-1]: org.jivesoftware.openfire.http.HttpBindManager - Error starting HTTP bind service
java.io.IOException: Failed to bind to 0.0.0.0/0.0.0.0:7070
at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConnector.java:346) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.ServerConnector.open(ServerConnector.java:308) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.AbstractNetworkConnector.doStart(AbstractNetworkConnector.java:80) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.ServerConnector.doStart(ServerConnector.java:236) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) ~[jetty-util-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.server.Server.doStart(Server.java:396) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:68) ~[jetty-util-9.4.18.v20190429.jar:9.4.18.v20190429]
at org.jivesoftware.openfire.http.HttpBindManager.start(HttpBindManager.java:241) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.startListeners(ConnectionManagerImpl.java:327) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.spi.ConnectionManagerImpl.access$100(ConnectionManagerImpl.java:46) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.spi.ConnectionManagerImpl$1.pluginsMonitored(ConnectionManagerImpl.java:304) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.container.PluginManager.firePluginsMonitored(PluginManager.java:1292) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.container.PluginManager.firePluginsMonitored(PluginManager.java:1285) [xmppserver-4.4.0.jar:4.4.0]
at org.jivesoftware.openfire.container.PluginMonitor$MonitorTask.run(PluginMonitor.java:428) [xmppserver-4.4.0.jar:4.4.0]
at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) [?:1.8.0_161]
at java.util.concurrent.FutureTask.runAndReset(Unknown Source) [?:1.8.0_161]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$301(Unknown Source) [?:1.8.0_161]
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(Unknown Source) [?:1.8.0_161]
at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) [?:1.8.0_161]
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) [?:1.8.0_161]
at java.lang.Thread.run(Unknown Source) [?:1.8.0_161]
Caused by: java.net.BindException: Address already in use: bind
at sun.nio.ch.Net.bind0(Native Method) ~[?:1.8.0_161]
at sun.nio.ch.Net.bind(Unknown Source) ~[?:1.8.0_161]
at sun.nio.ch.Net.bind(Unknown Source) ~[?:1.8.0_161]
at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source) ~[?:1.8.0_161]
at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source) ~[?:1.8.0_161]
at org.eclipse.jetty.server.ServerConnector.openAcceptChannel(ServerConnector.java:342) ~[jetty-server-9.4.18.v20190429.jar:9.4.18.v20190429]
… 20 more
2019.08.01 11:04:53 INFO [Jetty-QTP-AdminConsole-29]: org.jivesoftware.util.cache.CacheFactory - Created cache [org.jivesoftware.util.cache.DefaultLocalCacheStrategy] for Locked Out Accounts

Something is using 7070 port on the server. I guess something was installed.